subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Branko ─îibej <br...@apache.org>
Subject Re: svn_repos_fs_commit_txn error
Date Tue, 24 Nov 2015 05:13:29 GMT
On 23.11.2015 21:01, Ren Wang wrote:
> I got an error for creating a new directory to the repository. Strange to me
> is that enve the code failed at the svn_repos_fs_commit_txn, but the
> directory got created:
>
>  
>
>  
>
> 1)      Open repository, repos
>
> 2)      Get the latest revision, youngest
>
> 3)      Do the following:
>
> svn_fs_txn_t *txn;
>
> svn_fs_root_t *txn_root;
>
> apr_pool_t *subpool = svn_pool_create(pool);
>
> SVN_ERR(svn_repos_fs_begin_txn_for_commit(&txn, &repos, youngest_rev,
> "UncleYinan", "log msg", subpool));
>
> SVN_ERR(svn_fs_txn_root(&txn_root, txn, subpool));
>
> SVN_ERR(svn_fs_make_dir(txn_root, directoryPath, subpool));
>
> SVN_ERR(svn_repos_fs_commit_txn(NULL, c->repos, &youngest_rev, txn,
> subpool));    -- failed here
>
>  
>
> From the debugger call stack, the code failed at the
> svn_fs_fs__open_cache():
>
>  
>
> svn_repos_fs_commit_txn
>
>   svn_fs_commit_txn
>
>      svn_fs_fs__commit
>
>         svn_fs_fs__open_rep_cache
>
>  
>
>  
>
> Not sure if anyone saw this before? I must have missed something, but the
> code logic is too much to understand.


Can you please provide a complete, working program that shows your
problem? It's really, really hard to debug API issues from some
description of what the code does. Better to show the code instead.

-- Brane

Mime
View raw message