subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cotrut, Michael" <Michael.Cot...@cbsa-asfc.gc.ca>
Subject RE: Issue with browsing a SVN 1.9.2, schema 7, packed, repository
Date Fri, 11 Dec 2015 13:32:10 GMT
Hi Stefan,

Thanks for  your email.  
We've done two things. One, we realized that our tag folder is to flat and we made an archive
organized by release, this moved about 4000 tags in a subfolder.
Second, the settings you suggested also made a big difference , this is what we ended up with:

<IfModule dav_svn_module>
  # Enable a 1 Gb Subversion data cache for both fulltext and deltas.
  SVNInMemoryCacheSize 1048576
  SVNCacheTextDeltas On
  SVNCacheFullTexts On
  MaxMemFree 4096
</IfModule>

This fixed the issue we had and also improved performance in general. Thank you so much for
your help.

Thanks,

Michael Cotrut
Consultant, DevCentre 
Canada Border Services Agency 
Place Vanier, 333 North River road, 17th floor, Tower A, 17th Floor 17077 
Ottawa, Ontario
343-291-6097 Office

-----Original Message-----
From: Stefan Fuhrmann [mailto:stefan2@apache.org] 
Sent: December 10, 2015 7:42 AM
To: users@subversion.apache.org; Cotrut, Michael
Subject: Re: Issue with browsing a SVN 1.9.2, schema 7, packed, repository

> Hi,
>
> We've been using SVN for a couple of years, recently we migrated from 1.7.6 to 1.9.2.
We also
> migrated (dump and load) some of the larger repositories to schema 7 and packed them.

So, you have not tried the old repository format with 1.9.2?
If you should have a copy of that available (backup?), put
that one onto the server in a separate dir/location, e.g.
"my-repo-old".  Test whether the problem occurs with the old
format as well.

> One of this recently migrated repositories (  SVN 1.9.2 schema 7 repository)  is about
100
> GB mostly jar files under tags. About 9000 tags.

Format 7 will hardly give you any advantage with large binary
files without deep histories. Results may differ, though.

9000 entries in a single directory is a lot but not excessive.

> When browsing  the root/tags with TortoiseSVN 1.9.2 the operation hangs and causes  the
server
> to recycle after a couple of minutes.  This happens consistently every single time we
try
> to browse the root/tags of the repository.
> We've got same issue when testing SmartSVN.

It sounds like your server is running out of memory. Observe
the memory usage of the httpd.exe processes (there may be 2
of them) while running the request.

> The same browsing operation was working in 1.7.6, would take a couple of minutes (4-5)
 but
> was working.

My guess is that SVN 1.9.2 simply uses slightly more memory
than 1.7.6 did.  A normal 'svn ls -v' should take only a
second or so.  The long execution time is a strong indicator
that your server is doing something expensive and possibly
memory-consuming.  So, while 1.7.6 might have kept it just
below the out-of-memory threshold, 1.9.2 needs a few percent
more and crosses it.

> Faulting application httpd.exe, version 2.2.29.0, time stamp 0x5550b4ed, faulting module
libsvn_subr-1.dll,
> version 1.9.2.65436, time stamp 0x561e5208, exception code 0x40000015, fault offset 0x00026624,
> process id 0x968, application start time 0x01d131b996a721ff.

0x40000015 is basically an "abort".  We do this when we need
more memory but can't get it.

9000 directory entries is around the capacity of the default
cache configuration (16MB).  Make sure, you set the cache to
at least 100MB ("SVNInMemoryCacheSize 102400" in httpd.conf)
but NOT larger than 1GB in case you are using 32 bit Apache.

Set "MaxMemFree" in httpd.conf to something like 4096.  The
default of 0 is problematic.

Also, there is a fair chance that you are using path-based
authorization (authz). Disable it and see whether that makes
a difference.  E.g. create a separate <Location> for the same
repo without authz.

Let us know what you found.

-- Stefan^2.



Mime
View raw message