subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jbl...@icloud.com
Subject Re: Commit blocked by pre-commit hook (exit code 255) with no output.
Date Thu, 03 Dec 2015 19:54:11 GMT

> On Dec 3, 2015, at 9:40 AM, foven <effoven@gmail.com> wrote:
> 
> On Wed, Dec 2, 2015 at 9:50 PM, Nico Kadel-Garcia <nkadel@gmail.com <mailto:nkadel@gmail.com>>
wrote:
> On Wed, Dec 2, 2015 at 2:12 PM, foven <effoven@gmail.com <mailto:effoven@gmail.com>>
wrote:
> 
> > I looked at the output of "journalctl -n 50", which seems to be enough
> > to see all that is logged for a commit attempt.  I also checked
> > /var/log/secure.  I didn't see anything that seemed obviously wrong to
> > me either way, although it is possible that I missed something.  Are
> > there any other logs that I should check?
> >
> > Also, just to be clear, when I say that svn+ssh is not working, it is
> > working for checkouts and if I remove the pre-commit hook, it works for
> > commits as well.  Does it still seem likely that this is a ssh issue?
> >
> > Is there any more information I can provide that might help?
> 
> Start at the beginning: As whom is the "svn+ssh" connection being
> made? I assume it's the "phd" user, and that the SSH keys have been
> correctly configured?
> 
> Well, this repository is hosted by Phabricator.
> 

<…snip…>

> I hope this helps.  Please let me know if you need more information.
> 


This almost feels to me as if the path "/bin/sh" is not what it seems. Do you know if Phabricator
is using a chroot'd sshd implementation? They are usually rare since sshd does not provide
that by default, but I have seen some attempts.

-Joseph




Mime
View raw message