subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pavel Lyalyakin <pavel.lyalya...@visualsvn.com>
Subject Re: svn update issue
Date Wed, 20 Jul 2016 09:54:09 GMT
Stefan,

On Wed, Jul 20, 2016 at 11:47 AM, Stefan <luke1410@posteo.de> wrote:
> On 7/19/2016 23:26, Pavel Lyalyakin wrote:
>> Hello,
>>
>> On Tue, Jul 19, 2016 at 10:44 PM, ujjwala kaushik
>> <ujjwala.kaushik@gmail.com> wrote:
>>> Hi,
>>>
>>> I am using a I-Mac(Macintosh)  and I am trying to update the svn from terminal.
I had a old version which I uninstalled and then installed the latest subversion. The latest
1.9.2 is there on my system but I cannot update my files using that. I get the error message
below:
>>>
>>> What should i do? Any help would be appreciated.
>>>
>>> en4102194:~ ujjwalak15$ svn update
>>>
>>> Skipped '.'
>>>
>>> svn: E155007: None of the targets are working copies
>> The error means that the current working directory where you run `svn
>> update` is not a Subversion working copy. Make sure to provide correct
>> path to the working copy you are trying to update.
>>
>> BTW, make sure to `svn upgrade`[*] your working copies after upgrading
>> SVN client to 1.9 from 1.8 or older version. It's not related to the
>> error you've specified, though.
>>
>> [*]: http://svnbook.red-bean.com/en/1.8/svn.ref.svn.c.upgrade.html
> Pavel, svn upgrade is not required if you upgrade from 1.8 to 1.9 (only
> if u upgrade from <= 1.7 to >= 1.8) as far as I know, or am I wrong
> (aka: the WC format stayed the same between 1.8 and 1.9 [1])?
>
> [1] https://subversion.apache.org/docs/release-notes/1.9.html#wc-upgrade

Yep, you are right. I should've said that `svn upgrade` is required
when upgrading the SVN client to 1.9 from 1.7 or older. When upgrading
from 1.8 to 1.9 `svn upgrade` is not needed.

--
With best regards,
Pavel Lyalyakin
VisualSVN Team

Mime
View raw message