subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Sorensen <tsore...@co.jefferson.co.us>
Subject RE: Subversion dump/load - author
Date Tue, 13 Sep 2016 19:19:48 GMT
Hi –

Thank you for returning my email. To answer your question in the first sentence, yes, I am
talking about the files within the  repository tree. Let me first explain that the current
repository is
running on Linux. I access the repository through TortoiseSVN on my workstation using the
link that connects me to the repository on the Linux machine such as, https://pathtorepository/

Below is an example of the TortoiseSVN repository display header.

File                            Extension         Revision         Author   Size     Date
Accounting App                                   70                   jjones             
    01/01/2012
Budget App                                          135                 bsmith           
     04/16/1996
InventoryApp                                      16                   tfoxworth         
03/22/2001

When I create the dump file, I do so by directly logging into the Linux machine. From the
command line, I do the following;
$svnadmin dump /app/svn/csvn/data/repositories/nameofrepository  –r  7500 > prod1.dump

The prod1.dump file is create and I have a sys admin copy it to the Windows machine. I create
an empty repository on the Windows machine using subversion edge(collabnet) administration
console. I then perform the svnadmin load command. (I don’t remember the exact syntax but
I use force uuid). The load is successful and when I open the repository using TortoiseSVN
on the Windows machine, all of the Author’s names, in all the folders and sub folders, in
all revisions are the same, such as bsmith. Each time I do this, the Author’s name will
change, but the effect is the same. All of the Author’s names in all of the directories
and sub directories contain the same name. I’d like to keep the Author’s names as they
are displayed in the repository before the move.

Note:

At one time I had used a repository that was on a dev box, one that I used for experimentation.
I was able to load the entire repository without having to do the latest revision. Everything
displayed as expected. I tried to do a full dump of the production instance but the resulting
dump file was so large that I ran out of room. I also tried to dump it to a zip file, but
didn’t have
much luck.


Your problem is the dump file.  You only dumped a single revision of your repository rather
than the entire history of the repository.  Your SVN client is just showing the last changed
revision for each path which is probably now r1 and the author and date are whoever the author/date
for r7500 of your original repository was.

If you want to see your history you need to load a full dump file.


Thank you – I’ll need to consider dumping the entire repo or use it the way it is.

Tom
Mime
View raw message