subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joseph, Anselm" <Anselm.Jos...@fpl.com>
Subject RE: Error running make for subversion
Date Tue, 23 May 2017 12:40:26 GMT
Thank you Daniel for taking the time to answer. 

The complete configure command:
 CC='gcc' CPP='gcc -E' ./configure --prefix=/opt/eai/ci/subversion-1.9.5/svn --with-apache-libexecdir=/opt/eai/ci/httpd-2.2.32/apache/modules
--with-apr=/opt/eai/ci/httpd-2.2.32/srclib/apr/apr-1-config --with-apr-util=/opt/eai/ci/httpd-2.2.32/srclib/apr-util/apu-1-config
--with-apxs=/opt/eai/ci/httpd-2.2.32/apache/bin/apxs --disable-nls --enable-mod-activation
Not building in parallel, just running 'make' command.
Only one set of errors in config log:
configure:5703: checking for apr_memcache_create in -laprutil-1
configure:5728: gcc -o conftest -g -O2  -g -O2 -pthread   -U__STR__ -D_THREAD_SAFE -D_LARGEFILE64_SOURCE
 -I/opt/eai/ci/httpd-2.2.32/srclib/
apr/include   -I/opt/eai/ci/httpd-2.2.32/srclib/apr-util/include -I/opt/eai/ci/libiconv-1.15/libiconv/lib/include
-L/opt/freeware/lib  -L/op
t/eai/ci/httpd-2.2.32/srclib/apr-util -laprutil-1 conftest.c -laprutil-1   >&5
ld: 0711-317 ERROR: Undefined symbol: .apr_strtok
ld: 0711-317 ERROR: Undefined symbol: .apr_atoi64
ld: 0711-317 ERROR: Undefined symbol: .apr_pstrmemdup
...
ld: 0711-317 ERROR: Undefined symbol: .apr_pstrdup
ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain more information.
collect2: ld returned 8 exit status
configure:5728: $? = 1
configure: failed program was:
| /* confdefs.h */
-----Original Message-----
From: Daniel Shahaf [mailto:d.s@daniel.shahaf.name] 
Sent: Tuesday, May 23, 2017 4:59 AM
To: Joseph, Anselm
Cc: users@subversion.apache.org; Ryan Schmidt
Subject: Re: Error running make for subversion

You could try commenting out that 'chmod' command in Makefile or build-outputs.mk, see if
that lets the build proceed further, and then effect it manually after 'make' finishes.  (That's
just a diagnostic workaround, not a solution.)

What's your exact configure command (all arguments)?  Are you disabling building of shared
libraries in some way?

Are you building in parallel ('make -j' or local equivalent)?

Check configure's output for any errors/warnings related to httpd.  (If there's a warning
about "Assuming we use httpd 2.2+" that's normal.)

Don't have time to debug / reproduce myself, sorry.




Joseph, Anselm wrote on Mon, 22 May 2017 21:30 +0000:
> Hello All,
> I have been running in circles trying to fix this issue. Nothing seems to work. If you
could take a couple of minutes to give some direction, it would be greatly appreciated.
> Thank You
> 
> -----Original Message-----
> From: Joseph, Anselm
> Sent: Thursday, May 18, 2017 3:07 PM
> To: 'Ryan Schmidt'; Daniel Shahaf
> Cc: Subversion Users
> Subject: RE: Error running make for subversion
> 
> Thank you both for responding.
> When I run configure --without-apxs, make install completes cleanly. But my problem is
that mod_dav_svn.so is not building . I tried different options and still cannot get  mod_dav_svn.so
to build. 
> When I run .configure with-apxs= 
> /opt/eai/ci/httpd-2.2.32/apache/bin/apxs
> make install fails as follows:
> if true ; then cd subversion/mod_dav_svn ; 
> /opt/eai/ci/subversion/build/install-sh -c -d 
> "/opt/eai/ci/subversion-1.9.5/svn/libexec" ; 
> /opt/eai/ci/httpd-2.2.32/apache/bin/apxs -i -S 
> LIBEXECDIR="/opt/eai/ci/subversion-1.9.5/svn/libexec" -a -n dav_svn 
> mod_dav_svn.la ; fi /opt/eai/ci/httpd-2.2.32/apache/build/instdso.sh 
> SH_LIBTOOL='/opt/freeware/lib/apr-1/build/libtool' mod_dav_svn.la 
> /opt/eai/ci/subversion-1.9.5/svn/libexec
> rm -f /opt/eai/ci/subversion-1.9.5/svn/libexec/mod_dav_svn.so
> /opt/freeware/lib/apr-1/build/libtool --mode=install cp mod_dav_svn.la 
> /opt/eai/ci/subversion-1.9.5/svn/libexec/
> libtool: install: warning: relinking `mod_dav_svn.la'
> libtool: install: (cd /opt/eai/ci/subversion/subversion/mod_dav_svn; 
> /bin/sh "/opt/eai/ci/subversion/libtool"  --tag CC --silent 
> --mode=relink gcc -shared -g -O2 -g -O2 -pthread -L/opt/freeware/lib 
> -rpath /opt/eai/ci/subversion-1.9.5/svn/libexec -avoid-version -module 
> -o mod_dav_svn.la activity.lo authz.lo deadprops.lo liveprops.lo 
> lock.lo merge.lo mirror.lo mod_dav_svn.lo posts/create_txn.lo 
> reports/dated-rev.lo reports/deleted-rev.lo reports/file-revs.lo 
> reports/get-location-segments.lo reports/get-locations.lo 
> reports/get-locks.lo reports/inherited-props.lo reports/log.lo 
> reports/mergeinfo.lo reports/replay.lo reports/update.lo repos.lo 
> status.lo util.lo version.lo 
> ../../subversion/libsvn_repos/libsvn_repos-1.la 
> ../../subversion/libsvn_fs/libsvn_fs-1.la 
> ../../subversion/libsvn_delta/libsvn_delta-1.la 
> ../../subversion/libsvn_subr/libsvn_subr-1.la )
> libtool: install: cp .libs/mod_dav_svn.aT 
> /opt/eai/ci/subversion-1.9.5/svn/libexec/mod_dav_svn.a
> libtool: install: cp .libs/mod_dav_svn.lai 
> /opt/eai/ci/subversion-1.9.5/svn/libexec/mod_dav_svn.la
> chmod 755 /opt/eai/ci/subversion-1.9.5/svn/libexec/mod_dav_svn.so
> chmod: /opt/eai/ci/subversion-1.9.5/svn/libexec/mod_dav_svn.so: A file or directory in
the path name does not exist.
> apxs:Error: Command failed with rc=65536 .
> make: 1254-004 The error code from the last command is 1.
> 
> 
> Stop.
> 
> -----Original Message-----
> From: Ryan Schmidt [mailto:subversion-2016@ryandesign.com]
> Sent: Wednesday, May 17, 2017 8:42 PM
> To: Daniel Shahaf
> Cc: Joseph, Anselm; Subversion Users
> Subject: Re: Error running make for subversion
> 
> CAUTION - EXTERNAL EMAIL
> 
> 
> 
> > On May 17, 2017, at 19:41, Ryan Schmidt <subversion-2016@ryandesign.com> wrote:
> >
> >
> >> On May 16, 2017, at 17:18, Daniel Shahaf <d.s@daniel.shahaf.name> wrote:
> >>
> >> Joseph, Anselm wrote on Tue, May 16, 2017 at 21:04:57 +0000:
> >>> chmod: /opt/eai/ci/subversion-1.9.5/svn/libexec/mod_dav_svn.so: A file or
directory in the path name does not exist.
> >>> apxs:Error: Command failed with rc=65536
> >>
> >> Note that if you use svn:// or svn+ssh://, you don't need 
> >> mod_dav_svn and can disable building it with --without-apxs to configure.
> >
> > You mean http:// and https://. mod_dav_svn isn't involved with svn:// or svn+ssh://.
> >
> 
> And, sorry, I mis-parsed your sentence. Never mind.
> 
> 

Mime
View raw message