subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joseph, Anselm" <>
Subject RE: Error running make for subversion
Date Mon, 22 May 2017 21:30:31 GMT
Hello All,
I have been running in circles trying to fix this issue. Nothing seems to work. If you could
take a couple of minutes to give some direction, it would be greatly appreciated.
Thank You

-----Original Message-----
From: Joseph, Anselm 
Sent: Thursday, May 18, 2017 3:07 PM
To: 'Ryan Schmidt'; Daniel Shahaf
Cc: Subversion Users
Subject: RE: Error running make for subversion

Thank you both for responding.
When I run configure --without-apxs, make install completes cleanly. But my problem is that is not building . I tried different options and still cannot get
to build. 
When I run .configure with-apxs= /opt/eai/ci/httpd-2.2.32/apache/bin/apxs
make install fails as follows:
if true ; then cd subversion/mod_dav_svn ; /opt/eai/ci/subversion/build/install-sh -c -d "/opt/eai/ci/subversion-1.9.5/svn/libexec"
; /opt/eai/ci/httpd-2.2.32/apache/bin/apxs -i -S LIBEXECDIR="/opt/eai/ci/subversion-1.9.5/svn/libexec"
-a -n dav_svn ; fi /opt/eai/ci/httpd-2.2.32/apache/build/ SH_LIBTOOL='/opt/freeware/lib/apr-1/build/libtool' /opt/eai/ci/subversion-1.9.5/svn/libexec
rm -f /opt/eai/ci/subversion-1.9.5/svn/libexec/
/opt/freeware/lib/apr-1/build/libtool --mode=install cp /opt/eai/ci/subversion-1.9.5/svn/libexec/
libtool: install: warning: relinking `'
libtool: install: (cd /opt/eai/ci/subversion/subversion/mod_dav_svn; /bin/sh "/opt/eai/ci/subversion/libtool"
 --tag CC --silent --mode=relink gcc -shared -g -O2 -g -O2 -pthread -L/opt/freeware/lib -rpath
/opt/eai/ci/subversion-1.9.5/svn/libexec -avoid-version -module -o activity.lo
authz.lo deadprops.lo liveprops.lo lock.lo merge.lo mirror.lo mod_dav_svn.lo posts/create_txn.lo
reports/dated-rev.lo reports/deleted-rev.lo reports/file-revs.lo reports/get-location-segments.lo
reports/get-locations.lo reports/get-locks.lo reports/inherited-props.lo reports/log.lo reports/mergeinfo.lo
reports/replay.lo reports/update.lo repos.lo status.lo util.lo version.lo ../../subversion/libsvn_repos/
../../subversion/libsvn_fs/ ../../subversion/libsvn_delta/
../../subversion/libsvn_subr/ )
libtool: install: cp .libs/mod_dav_svn.aT /opt/eai/ci/subversion-1.9.5/svn/libexec/mod_dav_svn.a
libtool: install: cp .libs/mod_dav_svn.lai /opt/eai/ci/subversion-1.9.5/svn/libexec/
chmod 755 /opt/eai/ci/subversion-1.9.5/svn/libexec/
chmod: /opt/eai/ci/subversion-1.9.5/svn/libexec/ A file or directory in the
path name does not exist.
apxs:Error: Command failed with rc=65536 .
make: 1254-004 The error code from the last command is 1.


-----Original Message-----
From: Ryan Schmidt []
Sent: Wednesday, May 17, 2017 8:42 PM
To: Daniel Shahaf
Cc: Joseph, Anselm; Subversion Users
Subject: Re: Error running make for subversion


> On May 17, 2017, at 19:41, Ryan Schmidt <> wrote:
>> On May 16, 2017, at 17:18, Daniel Shahaf <> wrote:
>> Joseph, Anselm wrote on Tue, May 16, 2017 at 21:04:57 +0000:
>>> chmod: /opt/eai/ci/subversion-1.9.5/svn/libexec/ A file or directory
in the path name does not exist.
>>> apxs:Error: Command failed with rc=65536
>> Note that if you use svn:// or svn+ssh://, you don't need mod_dav_svn 
>> and can disable building it with --without-apxs to configure.
> You mean http:// and https://. mod_dav_svn isn't involved with svn:// or svn+ssh://.

And, sorry, I mis-parsed your sentence. Never mind.

View raw message