subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joseph, Anselm" <Anselm.Jos...@fpl.com>
Subject RE: Error running make for subversion
Date Tue, 23 May 2017 14:42:22 GMT
From config.status...
libext='a'
shrext_cmds='.so'

Sending the config.log for completeness. I am sure I am missing something...just don't know
what.
Thank you for your help.


-----Original Message-----
From: Daniel Shahaf [mailto:d.s@daniel.shahaf.name] 
Sent: Tuesday, May 23, 2017 9:26 AM
To: Joseph, Anselm
Cc: Ryan Schmidt; users@subversion.apache.org
Subject: Re: Error running make for subversion

CAUTION - EXTERNAL EMAIL



Joseph, Anselm wrote on Tue, 23 May 2017 12:40 +0000:
> configure:5703: checking for apr_memcache_create in -laprutil-1
> configure:5728: gcc -o conftest -g -O2  -g -O2 -pthread   -U__STR__ -D_THREAD_SAFE -D_LARGEFILE64_SOURCE
 -I/opt/eai/ci/httpd-2.2.32/srclib/
> apr/include   -I/opt/eai/ci/httpd-2.2.32/srclib/apr-util/include -I/opt/eai/ci/libiconv-1.15/libiconv/lib/include
-L/opt/freeware/lib  -L/op
> t/eai/ci/httpd-2.2.32/srclib/apr-util -laprutil-1 conftest.c -laprutil-1   >&5
> ld: 0711-317 ERROR: Undefined symbol: .apr_strtok
> ld: 0711-317 ERROR: Undefined symbol: .apr_atoi64
> ld: 0711-317 ERROR: Undefined symbol: .apr_pstrmemdup ...
> ld: 0711-317 ERROR: Undefined symbol: .apr_pstrdup

These errors are odd: if the linker couldn't find these function, Subversion would fail to
link.  (All libraries, not just mod_dav_svn.) But you build and install successfully without
mod_dav_svn...

More below.

> ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain more information.
> collect2: ld returned 8 exit status
> configure:5728: $? = 1
> configure: failed program was:
> | /* confdefs.h */
> -----Original Message-----
> Joseph, Anselm wrote on Mon, 22 May 2017 21:30 +0000:
> > -----Original Message-----
> > From: Joseph, Anselm
> > Sent: Thursday, May 18, 2017 3:07 PM
> ⋮
> > libtool: install: warning: relinking `mod_dav_svn.la'
> > libtool: install: (cd /opt/eai/ci/subversion/subversion/mod_dav_svn;
> > /bin/sh "/opt/eai/ci/subversion/libtool"  --tag CC --silent 
> > --mode=relink gcc -shared -g -O2 -g -O2 -pthread -L/opt/freeware/lib 
> > -rpath /opt/eai/ci/subversion-1.9.5/svn/libexec -avoid-version 
> > -module -o mod_dav_svn.la activity.lo authz.lo deadprops.lo 
> > liveprops.lo lock.lo merge.lo mirror.lo mod_dav_svn.lo 
> > posts/create_txn.lo reports/dated-rev.lo reports/deleted-rev.lo 
> > reports/file-revs.lo reports/get-location-segments.lo 
> > reports/get-locations.lo reports/get-locks.lo 
> > reports/inherited-props.lo reports/log.lo reports/mergeinfo.lo 
> > reports/replay.lo reports/update.lo repos.lo status.lo util.lo 
> > version.lo ../../subversion/libsvn_repos/libsvn_repos-1.la
> > ../../subversion/libsvn_fs/libsvn_fs-1.la
> > ../../subversion/libsvn_delta/libsvn_delta-1.la
> > ../../subversion/libsvn_subr/libsvn_subr-1.la )
> > libtool: install: cp .libs/mod_dav_svn.aT 
> > /opt/eai/ci/subversion-1.9.5/svn/libexec/mod_dav_svn.a
> > libtool: install: cp .libs/mod_dav_svn.lai 
> > /opt/eai/ci/subversion-1.9.5/svn/libexec/mod_dav_svn.la
> > chmod 755 /opt/eai/ci/subversion-1.9.5/svn/libexec/mod_dav_svn.so
> > chmod: /opt/eai/ci/subversion-1.9.5/svn/libexec/mod_dav_svn.so: A file or directory
in the path name does not exist.

On my machine, the output of 'make install' contains:

libtool: install: install .libs/mod_dav_svn.soT /srv/svn/trunk/libexec/mod_dav_svn.so
libtool: install: install .libs/mod_dav_svn.lai /srv/svn/trunk/libexec/mod_dav_svn.la
libtool: install: install .libs/mod_dav_svn.a /srv/svn/trunk/libexec/mod_dav_svn.a

The interesting thing here is that on my machine, it outputs .soT and .lai in this order,
whereas on your machine, it outputs .aT and .lai and then fails.  Perhaps configure had gotten
the .so and .a endings swapped, and thinks shared libraries are .a and static libraries .so
.
Can you check that?

On my machine:

$ grep -B1 shrext_cmds= config.status libtool config.status-libext='a'
config.status:shrext_cmds='.so'
--
libtool-# Shared library suffix (normally ".so").
libtool:shrext_cmds=".so"

I'm not sure where the 755 comes from, perhaps it's from httpd/apxs since there are no '755'
in svn's source code.

HTH.  And sorry for the delay, I haven't had a mod_dav_svn build environment until today.

Daniel


> > apxs:Error: Command failed with rc=65536 .
> > make: 1254-004 The error code from the last command is 1.

Mime
View raw message