subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jessica Ryan <jr...@tech4learning.com>
Subject Re: Sparse Checkout not working correctly?
Date Fri, 16 Feb 2018 20:08:49 GMT
Slaps forehead.

False alarm.  I’m sorry.  It turns out the parent directory of ‘code’ was somehow locally
under version control (had a .svn dir).  

Nevermind,
Jess



> On Feb 16, 2018, at 12:50 PM, Jessica Ryan <jryan@tech4learning.com> wrote:
> 
> In prior versions of SVN (last I checked that it worked was 1.7.x) I could do a sparse
checkout and things worked as expected.. for example:
> 
> Say I’m in a directory called code and do:
>> svn co http://blabla/svn trunk --depth=empty 
> 
> I then see code/trunk
> 
> and if, while still in the code dir, I do
>> svn st
> 
> I get a little message that says the code dir isn’t under version control.  Makes sense.
 I can then cd into trunk and continue to sparsely update particular directories from the
svn repo and all is well.
> 
> HOWEVER.  :)  Now, with 1.8 and 1.9, I’m seeing an issue.. 
> 
> Say I’m in my code dir and do
>> svn co http://blabla/svn trunk --depth=empty 
> 
> Now if I do
>> svn st
> I see as the result:
> A     .
> ?     trunk
> 
> And things get funky when trying to check stuff in.
> 
> I browsed your bug db and didn’t see any issues that looked like this, and I didn’t
see anything interesting come up doing a google search to see if others are experiencing this..
My svn server version is 1.8.10.  The client is running on Mac 10.13.3 and is version 1.9.7
(r1800392)
>   compiled Jan 12 2018, 19:11:29 on x86_64-apple-darwin17.3.0.
> 
> Let me know if there’s any more info I can provide!
> Thanks,
> Jessica Ryan
> 
> 



Mime
View raw message