subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Branko Čibej <br...@apache.org>
Subject Re: Strange libtool errors when try to build pyhton and ruby bindings (1.10.0)
Date Mon, 16 Apr 2018 08:36:34 GMT
On 15.04.2018 21:30, Branko Čibej wrote:
> On 13.04.2018 18:20, Lev Serebryakov wrote:
>>  I'm preparing FreeBSD of subversion-1.10.0 and have very strange errors
>> when try to build bindings.
>>
>>  subversion itself builds without problems.
> I just created a FreeBSD 11 virtual machine tried building the 1.10.0
> source tarball and ... well, I can confirm this report. I couldn't build
> the Perl bindings either, due to a missing header.
>
> However, when I installed autoconf, libtool and swig30, and started with
> a clean tree (make extraclean; ./autogen.sh; ./configure ...), I could
> build JavaHL and all the Swig bindings — with the standard deluge of
> missing typemap warnings. I could run the Perl, Python and JavaHL tests,
> but not the Ruby tests, the latter apparently due to a missing dependency.
>
> It makes me wonder what went wrong with the build scripts generation in
> the release package, because the builds worked fine on Linux, macOS and
> OpenBSD. The other possibility is that FreeBSD is simply weird ...

The problem is that Swig has become a build-time dependency now. We
don't configure the Swig bindings unless Swig is installed, even if the
binding sources are already generated — as they are in the release tarballs.

The solution is to install Swig and tell configure about it:

    $ sudo pkg install swig30
    $ ./configure --with-swig=/usr/local/bin/swig30 ...


This will not cause the Swig sources to be regenerated, but will perform
the proper configuration to make them compile correctly.

I consider this to be a bug in our build scripts, FWIW.

-- Brane


Mime
View raw message