subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Mueller <ss7...@gmail.com>
Subject configure not finding serf lib
Date Wed, 15 May 2019 20:20:12 GMT
Wondering if I could get help with configuring serf 1.39 with subversion
1.12 on a SLES 11.4 box.



Background



SLES 11.4 just came off long term support.



We still have to support quite a few SLES 11.4 machines. Our svn admin has
tightened security requirements and the svn revisions we were using on SLES
11.4 no longer work.



We are attempting to remediate by compiling subversion 1.12 on a SLES 11.4.



We are accustomed to compiling Openssl from tarballs on SLES 11.4. We are
currently using 1.0.2.



The first attempt to use a freshly compiled svn went as follows:



dev@cardamom:/NAS/dev> svn --version

svn, version 1.12.0 (r1857323)

   compiled May 15 2019, 09:35:22 on x86_64-unknown-linux-gnu





dev@cardamom:/NAS/dev> svn co https://svn/xxx/zzz/trunk/APPS
<https://svn/raleigh/tpm/trunk/APPS>

svn: E170000: Unrecognized URL scheme for 'https://svn/xxx/zzz/trunk/APPS
<https://svn/raleigh/tpm/trunk/APPS>'





Looks like we need to configure with serf. Download 1.39. Install SCons.
Build as follows:



dev@cardamom:~/wrk/sandbox/svn/serf-1.3.9> scons
OPENSSL=/home/dev/wrk/openssl_build/save/1.0.2n APR=/usr/local/apr
APU=/usr/local/apr



Ran "scons install" as root.



Rebuild svn:



dev@cardamom:~/wrk/sandbox/svn/subversion-1.12.0> ./configure
--with-lz4=internal  --with-utf8proc=internal --with-serf=/usr/local

configure: Configuring Subversion 1.12.0

configure: creating config.nice

checking for gcc... gcc

checking whether the C compiler works... yes

checking for C compiler default output file name... a.out

checking for suffix of executables...

checking whether we are cross compiling... no

checking for suffix of object files... o

checking whether we are using the GNU C compiler... yes

checking whether gcc accepts -g... yes

checking for gcc option to accept ISO C89... none needed

checking if gcc accepts -std=c90... no

checking if gcc accepts -std=c89... yes

checking if gcc accepts -w... yes

checking if gcc accepts -Werror=unknown-warning-option... no

checking for g++... g++

checking whether we are using the GNU C++ compiler... yes

checking whether g++ accepts -g... yes

checking if g++ accepts -std=c++11... no

checking if g++ accepts -w... yes

checking if g++ accepts -Werror=unknown-warning-option... no

checking how to run the C preprocessor... gcc -E

checking for a sed that does not truncate output... /usr/bin/sed

checking build system type... x86_64-unknown-linux-gnu

checking host system type... x86_64-unknown-linux-gnu

checking target system type... x86_64-unknown-linux-gnu

checking for grep that handles long lines and -e... /usr/bin/grep

checking for egrep... /usr/bin/grep -E

checking whether ln -s works... yes

checking for a BSD-compatible install... /usr/bin/install -c

configure: Apache Portable Runtime (APR) library configuration

checking for APR... yes

checking APR version... 1.7.0

configure: Apache Portable Runtime Utility (APRUTIL) library configuration

checking for APR-util... yes

checking APRUTIL version... 1.6.1

checking for pkg-config... /usr/bin/pkg-config

checking for ANSI C header files... yes

checking for sys/types.h... yes

checking for sys/stat.h... yes

checking for stdlib.h... yes

checking for string.h... yes

checking for memory.h... yes

checking for strings.h... yes

checking for inttypes.h... yes

checking for stdint.h... yes

checking for unistd.h... yes

configure: serf library configuration via pkg-config

checking for serf-2 library... no

checking for serf-1 library... no

configure: serf library configuration via prefix-/usr/local

checking serf.h usability... yes

checking serf.h presence... yes

checking for serf.h... yes

checking for serf_context_create in -lserf-1... no

checking was serf enabled... no



An appropriate version of serf could not be found, so libsvn_ra_serf

will not be built.  If you want to build libsvn_ra_serf, please

install serf 1.3.4 or newer.



configure: error: Serf was explicitly enabled but an appropriate version
was not found.





Make sure serf was installed correctly:



dev@cardamom:~/wrk/sandbox/svn/serf-1.3.9> cmp libserf-1.so.1.3.0
/usr/local/lib/libserf-1.so.1.3.0

dev@cardamom:~/wrk/sandbox/svn/serf-1.3.9>



Manually check if label is in lib:



dev@cardamom:~/wrk/sandbox/svn/subversion-1.12.0> strings
/usr/local/lib/libserf-1.so.1.3.0 | grep serf_context_create

serf_context_create_ex

serf_context_create



>From what I can tell from reading the configure script, a test file is
being compiled to see if serf_context_create is in the library it compiles
with.  I have not been able to get the script to divulge which lib it is
using yet.



Any help getting svn configure to work with serf would be much appreciated.



Thanks

Mike



Refs.:

https://svn.haxx.se/users/archive-2017-06/0040.shtml

Mime
View raw message