superset-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frankie Zhou <henryj...@gmail.com>
Subject Re: resource version conflict when running "run_tests.sh"
Date Fri, 28 Jul 2017 05:28:44 GMT
Thank you very much!

On Fri, Jul 28, 2017 at 2:03 PM, Maxime Beauchemin <
maximebeauchemin@gmail.com> wrote:

> Try `pip install -e .` from the main folder. It's similar to `python
> setup.py develop`. If that doesn't work just go `pip install requests==
> 2.17.3`
>
> Max
>
> On Thu, Jul 27, 2017 at 6:58 PM, Frankie Zhou <henryjoye@gmail.com> wrote:
>
> > Hi all,
> >
> > I successfully set up the Python dev environment javascript environment
> > following the CONTRIBUTING doc. However, when I run "run_tests.sh" in the
> > superset root folder, I got the following errors on the resource version
> > conflict as shown at the end of the message. Would you please give me any
> > message on how to solve it? Thank you very much!
> > Frankie
> >
> > running nosetests
> > running egg_info
> > writing dependency_links to superset.egg-info/dependency_links.txt
> > writing top-level names to superset.egg-info/top_level.txt
> > writing requirements to superset.egg-info/requires.txt
> > writing superset.egg-info/PKG-INFO
> > reading manifest file 'superset.egg-info/SOURCES.txt'
> > reading manifest template 'MANIFEST.in'
> > warning: no previously-included files matching '*' found under directory
> > 'superset/static/docs'
> > warning: no previously-included files matching '*' found under directory
> > 'superset/static/spec'
> > writing manifest file 'superset.egg-info/SOURCES.txt'
> > Searching for sqlalchemy==1.1.9
> > Best match: SQLAlchemy 1.1.9
> > Processing SQLAlchemy-1.1.9-py3.5-linux-x86_64.egg
> >
> > Using
> > /home/user1/anaconda3/envs/py35/lib/python3.5/site-
> > packages/SQLAlchemy-1.1.9-py3.5-linux-x86_64.egg
> > Traceback (most recent call last):
> >   File "setup.py", line 93, in <module>
> >     'Programming Language :: Python :: 3.5',
> >   File "/home/user1/anaconda3/envs/py35/lib/python3.5/distutils/
> core.py",
> > line 148, in setup
> >     dist.run_commands()
> >   File "/home/user1/anaconda3/envs/py35/lib/python3.5/distutils/
> dist.py",
> > line 955, in run_commands
> >     self.run_command(cmd)
> >   File "/home/user1/anaconda3/envs/py35/lib/python3.5/distutils/
> dist.py",
> > line 974, in run_command
> >     cmd_obj.run()
> >   File
> > "/home/user1/anaconda3/envs/py35/lib/python3.5/site-
> > packages/nose/commands.py",
> > line 144, in run
> >     self.distribution.install_requires)
> >   File
> > "/home/user1/anaconda3/envs/py35/lib/python3.5/site-
> > packages/setuptools-27.2.0-py3.5.egg/setuptools/dist.py",
> > line 361, in fetch_build_eggs
> >   File
> > "/home/user1/anaconda3/envs/py35/lib/python3.5/site-
> > packages/setuptools-27.2.0-py3.5.egg/pkg_resources/__init__.py",
> > line 851, in resolve
> >   File
> > "/home/user1/anaconda3/envs/py35/lib/python3.5/site-
> > packages/setuptools-27.2.0-py3.5.egg/pkg_resources/__init__.py",
> > line 1116, in best_match
> >   File
> > "/home/user1/anaconda3/envs/py35/lib/python3.5/site-
> > packages/setuptools-27.2.0-py3.5.egg/pkg_resources/__init__.py",
> > line 720, in find
> > pkg_resources.VersionConflict: (requests 2.11.1
> > (/home/user1/anaconda3/envs/py35/lib/python3.5/site-packages),
> > Requirement.parse('requests==2.17.3'))
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message