superset-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frankie Zhou <henryj...@gmail.com>
Subject building errors when running "npm run prod"
Date Mon, 24 Jul 2017 11:52:19 GMT
Hi all,

I am new to superset and trying to build fresh superset on my own computer.

I follow the steps in "CONTRIBUTING.md" to set up the dev and javascript
environment. When I run "npm run prod" in the "assets" folder, I got
following errors:

ERROR in ./visualizations/mapbox.jsx
Module not found: Error: Can't resolve
'react-map-gl/dist/overlays/scatterplot.react' in
'/home/user/work/superset/superset/assets/visualizations'
 @ ./visualizations/mapbox.jsx 27:19-74
 @ ./visualizations/main.js
 @ ./javascripts/modules/superset.js
 @ ./javascripts/dashboard/Dashboard.jsx
 @ multi babel-polyfill ./javascripts/dashboard/Dashboard.jsx

ERROR in dashboard.a1e562ceb59e1ed7318d.entry.js from UglifyJs
Unexpected token: name (ARRAY_TYPE)
[dashboard.a1e562ceb59e1ed7318d.entry.js:47808,4]
......

I guess that this error is related to mapbox and react versions. But I am
not sure how to solve them. It is great if you have any ideas. Thank you
very much!

Regards,
Zhou

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message