synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Fremantle <pzf...@gmail.com>
Subject Re: FW: Mediator interface
Date Tue, 27 Sep 2005 19:16:26 GMT
Glen, Sanjiva

+1 to a String - I agree a QName is overcomplex.

I'm wondering if having the name in at all makes sense since the aim of the
IoC concept is to take out anything that isn't part of the business
interface. The mediate method is the business interface of this bean. Any
containment aspects should be separate (that is the concept behind IoC)
which is why to not include explicit init and destroy methods, since these
tie the objects to a particular containment model.

Paul

On 9/27/05, Sanjiva Weerawarana <sanjiva@opensource.lk> wrote:
>
> On Tue, 2005-09-27 at 14:21 -0400, Glen Daniels wrote:
> >
> > Can we make it a String for now and then QName-ify it if we need to go
> > there?
>
> +1 .. even if we do use policy attachment we could use the URI style of
> naming and then keeping them as strings is the way to go anyway.
>
> Sanjiva.
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: synapse-dev-unsubscribe@ws.apache.org
> For additional commands, e-mail: synapse-dev-help@ws.apache.org
>
>

Mime
View raw message