synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vikas" <vi...@infravio.com>
Subject Re: Problem with Deprecation Mediator
Date Wed, 01 Feb 2006 04:07:45 GMT
Hi SathaKarni,

The problem is not with the DeprecationMediator per-se.
I tried to reproduce the error. I started the Synapse server on port 9090 (using the -p option)
and then went on to run the StockQuote client using the ant task in the Samples folder.
It worked fine.

Try the -Dsynapseurl='the URL on which synapse server is available' while doing ant stockquote,
instead of changing the turl.
Must be a mis-configuration.

~Vikas


  ----- Original Message ----- 
  From: Satha Karni 
  To: synapse-dev@ws.apache.org 
  Sent: Monday, January 30, 2006 5:45 PM
  Subject: Problem with Deprecation Mediator


  Hi All,

  I am facing following problem while working with Deprecation Mediator sample that is packed
with Synapse-Incubating-M1-bin.

  stockquote:
       [java] [JAM] Warning: You are running under a pre-1.5 JDK.  JSR175-style so
  urce annotations will not be available
       [java] org.apache.axis2.AxisFault: Connection refused: connect; nested exce
  ption is:
       [java]     java.net.ConnectException: Connection refused: connect; nested e
  xception is:
       [java]     org.apache.axis2.AxisFault: Connection refused: connect; nested
  exception is:
       [java]     java.net.ConnectException: Connection refused: connect
       [java]     at org.apache.axis2.transport.http.CommonsHTTPTransportSender.in
  voke(CommonsHTTPTransportSender.java:245)
       [java]     at org.apache.axis2.engine.AxisEngine.send(AxisEngine.java:449)
       [java]     at org.apache.axis2.description.OutInAxisOperationClient.send(Ou
  tInAxisOperation.java:317)
       [java]     at org.apache.axis2.description.OutInAxisOperationClient.execute
  (OutInAxisOperation.java:267)
       [java]     at org.apache.axis2.client.ServiceClient.sendReceive(ServiceClie
  nt.java:393)
       [java]     at org.apache.axis2.client.ServiceClient.sendReceive(ServiceClie
  nt.java:326)
       [java]     at samples.userguide.StockQuoteClient.main(StockQuoteClient.java
  :96)
       [java] Caused by: org.apache.axis2.AxisFault: Connection refused: connect;
  nested exception is:
       [java]     java.net.ConnectException: Connection refused: connect
       [java]     at org.apache.axis2.transport.http.CommonsHTTPTransportSender.wr
  iteMessageWithCommons(CommonsHTTPTransportSender.java:290)
       [java]     at org.apache.axis2.transport.http.CommonsHTTPTransportSender.in
  voke(CommonsHTTPTransportSender.java:204)
       [java]     ... 6 more
       [java] Caused by: java.net.ConnectException: Connection refused: connect
       [java]     at java.net.PlainSocketImpl.socketConnect(Native Method)
       [java]     at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:305)
       [java]     at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.jav
  a:171)
       [java]     at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:158)
       [java]     at java.net.Socket.connect(Socket.java:452)
       [java]     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       [java]     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcces
  sorImpl.java:39)
       [java]     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMet
  hodAccessorImpl.java:25)
       [java]     at java.lang.reflect.Method.invoke(Method.java:324)
       [java]     at org.apache.commons.httpclient.protocol.ReflectionSocketFactor
  y.createSocket(ReflectionSocketFactory.java:139)
       [java]     at org.apache.commons.httpclient.protocol.DefaultProtocolSocketF
  actory.createSocket(DefaultProtocolSocketFactory.java:124)
       [java]     at org.apache.commons.httpclient.HttpConnection.open(HttpConnect
  ion.java:706)
       [java]     at org.apache.commons.httpclient.HttpMethodDirector.executeWithR
  etry(HttpMethodDirector.java:386)
       [java]     at org.apache.commons.httpclient.HttpMethodDirector.executeMetho
  d(HttpMethodDirector.java:170)
       [java]     at org.apache.commons.httpclient.HttpClient.executeMethod(HttpCl
  ient.java:396)
       [java]     at org.apache.commons.httpclient.HttpClient.executeMethod(HttpCl
  ient.java:346)
       [java]     at org.apache.axis2.transport.http.SOAPOverHTTPSender.send(SOAPO
  verHTTPSender.java:100)
       [java]     at org.apache.axis2.transport.http.CommonsHTTPTransportSender.wr
  iteMessageWithCommons(CommonsHTTPTransportSender.java:284)
       [java]     ... 7 more

  The following scenario is being employed:

  1)Started synapse in port 9090 by giving command-line:

  C:\synapse>bin\synapse.bat synapse_repository -p9090
  ***The synapse started smoothly*** 

  2)I have changed the turl in StockQuoteClient to 9090

  3)Re-started the synapse server and ran 'ant compile' ,'ant stockquote' as stated in the
README of the sample.

  Kindly know if I have done any mis-configuration. 

Mime
View raw message