synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sanka Samaranayake <sa...@apache.org>
Subject Re: Problems building (spring?)
Date Fri, 10 Mar 2006 11:35:01 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Glen Daniels wrote:
> So the most recent problem was the fact that the default maven
> configuration for Synapse was looking for policy-1.0-SNAPSHOT.jar, which
> isn't anywhere I could find on the repositories.  I have a local copy of
> WS-Commons, so I built policy there, which generated
> policy-0.92-SNAPSHOT.jar in my local repository.  I was then able to:
>
> maven -Dpolicy.version=0.92-SNAPSHOT
>
> and successfully build Synapse (the spring issue apparently
> disappeared). :)
>
> Anyone have a clue as to why the wrong policy version was being
> selected?  This maven stuff still isn't very clear to me....
>   
I've updated the project.properties with the correct policy version.
Please take a fresh checkout and it should work just fine.

sorry for the inconvenience !

Best,
Sanka
> --Glen 
>
>   
>> -----Original Message-----
>> From: Saminda Abeyruwan [mailto:samindaa@gmail.com] 
>> Sent: Wednesday, March 08, 2006 11:38 PM
>> To: synapse-dev@ws.apache.org
>> Subject: Re: Problems building (spring?)
>>
>> Hi, 
>>
>> A fresh build has been tested  with Linux and Windows and 
>> it's successfully. My wild guess is that the download 
>> spring-1.2.6.jar may be corrupted in your local repository. 
>> Try to clean the local repo and do a build. 
>>
>> Thank you
>>
>> Saminda 
>>
>>
>> On 3/9/06, Saminda Abeyruwan <samindaa@gmail.com> wrote:
>>
>> 	Hi, 
>> 	
>> 	
>> 	On 3/9/06, Glen Daniels < gdaniels@sonicsoftware.com 
>> <mailto:gdaniels@sonicsoftware.com> > wrote:
>>
>>
>> 		Hey Synapsians:
>> 		
>> 		When I sync the Synapse SVN and "maven", I end 
>> up getting a bunch of
>> 		errors when building the extensions module.  It 
>> looks like most of them
>> 		are about the Spring framework being missing, 
>> and indeed, my maven 
>> 		repository doesn't have local copies of the 
>> spring jars.  Is anyone else
>> 		seeing this behaviour?
>> 		
>> 		Is there a way I can force maven to manually 
>> download the spring jars?
>> 		
>> 		Incidentally, where does maven get the value 
>> for " spring.version" from?
>>
>>
>> 	This is getting from etc/project.properties.  
>> 	
>> 	I will look into this. 
>> 	
>> 	
>> 	Saminda 
>> 	
>> 	
>> 	
>>
>> 		Thanks for any tips,
>> 		--Glen
>> 		
>> 		
>> --------------------------------------------------------------------- 
>> 		To unsubscribe, e-mail: 
>> synapse-dev-unsubscribe@ws.apache.org
>> 		For additional commands, e-mail: 
>> synapse-dev-help@ws.apache.org 
>> 		
>> 		
>>
>>
>>
>>
>>     
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: synapse-dev-unsubscribe@ws.apache.org
> For additional commands, e-mail: synapse-dev-help@ws.apache.org
>
>
>   


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.1 (GNU/Linux)

iD8DBQFEEWRl/Hd0ETKdgNIRAkOmAJ48NpUIebZ3NjsmR/zyz8uUpBLlxQCcD5Tc
zpXC88gs4ylflW9AaNmFxH4=
=xH87
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: synapse-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: synapse-dev-help@ws.apache.org


Mime
View raw message