synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ant elder" <ant.el...@gmail.com>
Subject Re: Including dependency JARs with the Synapse distribution
Date Tue, 27 Mar 2007 21:25:09 GMT
This sounds ok to me if these jars are really necessary to use Rampart.
Having it work out of the box is much nicer than making a user have to
download extra bits.

So...how about also including the Rhino JavaScript engine as well? ;)

   ...ant

On 3/27/07, Asankha C. Perera <asankha@wso2.com> wrote:
>
> Hi All
>
> With the latest Rampart changes etc. Synapse requires a couple of
> dependency JARs in its lib folder to properly function. See
> https://issues.apache.org/jira/browse/SYNAPSE-80
>
> I propose that we include Xerces and Xalan with Synapse and provide out
> of the box support for Rampart, and move the XSLT and Validate mediators
> as well into the core package from extensions. This would add around 4MB
> into our binary download - but I do not think this would cause much
> trouble to anyone with good internet connections these days.. but make
> things easy for someone to quickly tryout Synapse within 5 minutes and
> see results
>
> asankha
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: synapse-dev-unsubscribe@ws.apache.org
> For additional commands, e-mail: synapse-dev-help@ws.apache.org
>
>

Mime
View raw message