synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Evanthika Amarasiri (JIRA)" <j...@apache.org>
Subject [jira] Updated: (SYNAPSE-131) Issues occurred regarding logging
Date Thu, 01 Nov 2007 08:05:50 GMT

     [ https://issues.apache.org/jira/browse/SYNAPSE-131?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Evanthika Amarasiri updated SYNAPSE-131:
----------------------------------------

    Description: 
Issue 1
=======
The log message printed when removing SOAP headers (usage of the "header" mediator) is printed
twice


[HttpClientWorker-1] DEBUG HeaderMediator Removing header : {http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd}Security
from current message
[HttpClientWorker-1] DEBUG HeaderMediator Removing SOAP Header : {http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd}Security


Issue 2
=======
When starting a sample, the log which describes the initialization of the Sequence mediator
is printed twice


[main] DEBUG SynapseConfiguration Initializing the Synapse Configuration
[main] DEBUG SequenceMediator Initializing child mediators
[main] DEBUG SequenceMediator Initializing child mediators
[main] DEBUG InMediator Initializing child mediators
[main] DEBUG OutMediator Initializing child mediators
[main] DEBUG SequenceMediator Initializing child mediators
[main] DEBUG SequenceMediator Initializing child mediators
[main]  INFO SynapseInitializationModule Deploying the Synapse service.


Issue 3
======
The following log is printed twice on the Synapse console


[HttpCoreNIOListener] DEBUG NativeWorkerPool Using native util.concurrent package..


Issue 4 -Trivial issue 
======
When the script mediator options are logged the following is logged with a "true" at the end
[HttpServerWorker-1] DEBUG ScriptMediator End : Script mediator true


I think the text "true" should be removed


Issue 5
======
When the JMS transport is enabled on the axis2.xml and when a sample is being started, the
following logs are printed twice. Is this correct or should one of the sets be omitted?

******************************************************************************************************************
2007-11-01 13:58:15,671 [10.100.1.228-Evan] [main]  INFO HttpCoreNIOSender HTTPS Sender starting
2007-11-01 13:58:15,671 [10.100.1.228-Evan] [main]  INFO HttpCoreNIOSender HTTP Sender starting
2007-11-01 13:58:15,875 [10.100.1.228-Evan] [main]  INFO HttpCoreNIOListener HTTPS Listener
starting on port : 8443
[SynapseServer] Starting transport https on port 8443
2007-11-01 13:58:15,875 [10.100.1.228-Evan] [main]  INFO HttpCoreNIOListener HTTP Listener
starting on port : 8080
[SynapseServer] Starting transport http on port 8080
[SynapseServer] Starting transport vfs
2007-11-01 13:58:16,000 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connected to
the JMS connection factory : TopicConnectionFactory
2007-11-01 13:58:16,375 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connection factory
: myTopicConnectionFactory initialized...
2007-11-01 13:58:16,375 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connected to
the JMS connection factory : QueueConnectionFactory
2007-11-01 13:58:16,390 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connection factory
: myQueueConnectionFactory initialized...
2007-11-01 13:58:16,390 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connected to
the JMS connection factory : QueueConnectionFactory
2007-11-01 13:58:16,406 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connection factory
: default initialized...
2007-11-01 13:58:16,406 [10.100.1.228-Evan] [main]  INFO VFSTransportListener JMS Transport
Receiver/Listener initialized...
2007-11-01 13:58:16,406 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Re-initializing
the JMS connection factory : myTopicConnectionFactory
2007-11-01 13:58:16,406 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connected to
the JMS connection factory : TopicConnectionFactory
2007-11-01 13:58:16,421 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connection factory
: myTopicConnectionFactory initialized...
2007-11-01 13:58:16,421 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Re-initializing
the JMS connection factory : myQueueConnectionFactory
2007-11-01 13:58:16,421 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connected to
the JMS connection factory : QueueConnectionFactory
2007-11-01 13:58:16,437 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connection factory
: myQueueConnectionFactory initialized...
2007-11-01 13:58:16,437 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Re-initializing
the JMS connection factory : default
2007-11-01 13:58:16,437 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connected to
the JMS connection factory : QueueConnectionFactory
2007-11-01 13:58:16,437 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connection factory
: default initialized...
[SynapseServer] Starting transport jms
[SynapseServer] Ready
******************************************************************************************************************

Issue 6
======
In sample 11, the same log is printed twice. Occurs when the ending of the "Send" mediator
of the incoming message is being logged


DEBUG SendMediator End : Send mediator
DEBUG SequenceMediator End : Sequence <dynamic_sequence>
DEBUG SequenceMediator End : Sequence <anonymous>
DEBUG SequenceMediator End : Sequence <main>
DEBUG SendMediator End : Send mediator
DEBUG SequenceMediator End : Sequence <dynamic_sequence>
DEBUG SequenceMediator End : Sequence <anonymous>
DEBUG SequenceMediator End : Sequence <main>


Sample 9


DEBUG SendMediator End : Send mediator
DEBUG SequenceMediator End : Sequence <main>
DEBUG SendMediator End : Send mediator
DEBUG SequenceMediator End : Sequence <main>


Issue 7
======
When a sequence exists in a configuration where it refers to another sequence through a reference
key, the logs are written as follows. (Refers to the sequence as anonymous)
DEBUG SequenceMediator Start : Sequence <anonymous>


This should be removed


Issue 8
======
When executing sample 700 (xquery), it prints the xquery code segment twice with different
headings. IMO one of these should be removed.


2007-10-16 10:11:51,517 [127.0.1.1-testc-ubuntu] [HttpServerWorker-1] DEBUG XQueryMediator
Picked up the xquery source 
  declare namespace m0="http://services.samples/xsd";
  declare variable $payload as document-node() external;
  <m:getQuote xmlns:m="http://services.samples/xsd">
    <m:request>
      <m:symbol>{$payload//m0:CheckPriceRequest/m0:Code/child::text()}</m:symbol>
    </m:request>
  </m:getQuote>

  was:
Issue 1
=======
The log message printed when removing SOAP headers (usage of the "header" mediator) is printed
twice

[HttpClientWorker-1] DEBUG HeaderMediator Removing header : {http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd}Security
from current message
[HttpClientWorker-1] DEBUG HeaderMediator Removing SOAP Header : {http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd}Security

Issue 2
=======
When starting a sample, the log which describes the initialization of the Sequence mediator
is printed twice

[main] DEBUG SynapseConfiguration Initializing the Synapse Configuration
[main] DEBUG SequenceMediator Initializing child mediators
[main] DEBUG SequenceMediator Initializing child mediators
[main] DEBUG InMediator Initializing child mediators
[main] DEBUG OutMediator Initializing child mediators
[main] DEBUG SequenceMediator Initializing child mediators
[main] DEBUG SequenceMediator Initializing child mediators
[main]  INFO SynapseInitializationModule Deploying the Synapse service.

Issue 3
======
The following log is printed twice on the Synapse console

[HttpCoreNIOListener] DEBUG NativeWorkerPool Using native util.concurrent package..

Issue 4 -Trivial issue 
======
When the script mediator options are logged the following is logged with a "true" at the end
[HttpServerWorker-1] DEBUG ScriptMediator End : Script mediator true

I think the text "true" should be removed

Issue 5
======
When the JMS transport is enabled on the axis2.xml and when a sample is being started, the
following logs are printed twice. Is this correct or should one of the sets be omitted?

INFO JMSConnectionFactory Connected to the JMS connection factory : TopicConnectionFactory
INFO JMSConnectionFactory Connection factory : myTopicConnectionFactory initialized...
INFO JMSConnectionFactory Connected to the JMS connection factory : QueueConnectionFactory
INFO JMSConnectionFactory Connection factory : myQueueConnectionFactory initialized...
INFO JMSConnectionFactory Connected to the JMS connection factory : QueueConnectionFactory
INFO JMSConnectionFactory Connection factory : default initialized...

Issue 6
======
In sample 11, the same log is printed twice. Occurs when the ending of the "Send" mediator
of the incoming message is being logged

DEBUG SendMediator End : Send mediator
DEBUG SequenceMediator End : Sequence <dynamic_sequence>
DEBUG SequenceMediator End : Sequence <anonymous>
DEBUG SequenceMediator End : Sequence <main>
DEBUG SendMediator End : Send mediator
DEBUG SequenceMediator End : Sequence <dynamic_sequence>
DEBUG SequenceMediator End : Sequence <anonymous>
DEBUG SequenceMediator End : Sequence <main>

Sample 9

DEBUG SendMediator End : Send mediator
DEBUG SequenceMediator End : Sequence <main>
DEBUG SendMediator End : Send mediator
DEBUG SequenceMediator End : Sequence <main>

Issue 7
======
When a sequence exists in a configuration where it refers to another sequence through a reference
key, the logs are written as follows. (Refers to the sequence as anonymous)
DEBUG SequenceMediator Start : Sequence <anonymous>

This should be removed

Issue 8
======
When executing sample 700 (xquery), it prints the xquery code segment twice with different
headings. IMO one of these should be removed.

2007-10-16 10:11:51,517 [127.0.1.1-testc-ubuntu] [HttpServerWorker-1] DEBUG XQueryMediator
Picked up the xquery source 
  declare namespace m0="http://services.samples/xsd";
  declare variable $payload as document-node() external;
  <m:getQuote xmlns:m="http://services.samples/xsd">
    <m:request>
      <m:symbol>{$payload//m0:CheckPriceRequest/m0:Code/child::text()}</m:symbol>
    </m:request>
  </m:getQuote>
 


> Issues occurred regarding logging 
> ----------------------------------
>
>                 Key: SYNAPSE-131
>                 URL: https://issues.apache.org/jira/browse/SYNAPSE-131
>             Project: Synapse
>          Issue Type: Bug
>         Environment: Windows XP, JDK1.5.0_06
>            Reporter: Evanthika Amarasiri
>            Priority: Minor
>
> Issue 1
> =======
> The log message printed when removing SOAP headers (usage of the "header" mediator) is
printed twice
> [HttpClientWorker-1] DEBUG HeaderMediator Removing header : {http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd}Security
from current message
> [HttpClientWorker-1] DEBUG HeaderMediator Removing SOAP Header : {http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd}Security
> Issue 2
> =======
> When starting a sample, the log which describes the initialization of the Sequence mediator
is printed twice
> [main] DEBUG SynapseConfiguration Initializing the Synapse Configuration
> [main] DEBUG SequenceMediator Initializing child mediators
> [main] DEBUG SequenceMediator Initializing child mediators
> [main] DEBUG InMediator Initializing child mediators
> [main] DEBUG OutMediator Initializing child mediators
> [main] DEBUG SequenceMediator Initializing child mediators
> [main] DEBUG SequenceMediator Initializing child mediators
> [main]  INFO SynapseInitializationModule Deploying the Synapse service.
> Issue 3
> ======
> The following log is printed twice on the Synapse console
> [HttpCoreNIOListener] DEBUG NativeWorkerPool Using native util.concurrent package..
> Issue 4 -Trivial issue 
> ======
> When the script mediator options are logged the following is logged with a "true" at
the end
> [HttpServerWorker-1] DEBUG ScriptMediator End : Script mediator true
> I think the text "true" should be removed
> Issue 5
> ======
> When the JMS transport is enabled on the axis2.xml and when a sample is being started,
the following logs are printed twice. Is this correct or should one of the sets be omitted?
> ******************************************************************************************************************
> 2007-11-01 13:58:15,671 [10.100.1.228-Evan] [main]  INFO HttpCoreNIOSender HTTPS Sender
starting
> 2007-11-01 13:58:15,671 [10.100.1.228-Evan] [main]  INFO HttpCoreNIOSender HTTP Sender
starting
> 2007-11-01 13:58:15,875 [10.100.1.228-Evan] [main]  INFO HttpCoreNIOListener HTTPS Listener
starting on port : 8443
> [SynapseServer] Starting transport https on port 8443
> 2007-11-01 13:58:15,875 [10.100.1.228-Evan] [main]  INFO HttpCoreNIOListener HTTP Listener
starting on port : 8080
> [SynapseServer] Starting transport http on port 8080
> [SynapseServer] Starting transport vfs
> 2007-11-01 13:58:16,000 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connected
to the JMS connection factory : TopicConnectionFactory
> 2007-11-01 13:58:16,375 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connection
factory : myTopicConnectionFactory initialized...
> 2007-11-01 13:58:16,375 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connected
to the JMS connection factory : QueueConnectionFactory
> 2007-11-01 13:58:16,390 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connection
factory : myQueueConnectionFactory initialized...
> 2007-11-01 13:58:16,390 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connected
to the JMS connection factory : QueueConnectionFactory
> 2007-11-01 13:58:16,406 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connection
factory : default initialized...
> 2007-11-01 13:58:16,406 [10.100.1.228-Evan] [main]  INFO VFSTransportListener JMS Transport
Receiver/Listener initialized...
> 2007-11-01 13:58:16,406 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Re-initializing
the JMS connection factory : myTopicConnectionFactory
> 2007-11-01 13:58:16,406 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connected
to the JMS connection factory : TopicConnectionFactory
> 2007-11-01 13:58:16,421 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connection
factory : myTopicConnectionFactory initialized...
> 2007-11-01 13:58:16,421 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Re-initializing
the JMS connection factory : myQueueConnectionFactory
> 2007-11-01 13:58:16,421 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connected
to the JMS connection factory : QueueConnectionFactory
> 2007-11-01 13:58:16,437 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connection
factory : myQueueConnectionFactory initialized...
> 2007-11-01 13:58:16,437 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Re-initializing
the JMS connection factory : default
> 2007-11-01 13:58:16,437 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connected
to the JMS connection factory : QueueConnectionFactory
> 2007-11-01 13:58:16,437 [10.100.1.228-Evan] [main]  INFO JMSConnectionFactory Connection
factory : default initialized...
> [SynapseServer] Starting transport jms
> [SynapseServer] Ready
> ******************************************************************************************************************
> Issue 6
> ======
> In sample 11, the same log is printed twice. Occurs when the ending of the "Send" mediator
of the incoming message is being logged
> DEBUG SendMediator End : Send mediator
> DEBUG SequenceMediator End : Sequence <dynamic_sequence>
> DEBUG SequenceMediator End : Sequence <anonymous>
> DEBUG SequenceMediator End : Sequence <main>
> DEBUG SendMediator End : Send mediator
> DEBUG SequenceMediator End : Sequence <dynamic_sequence>
> DEBUG SequenceMediator End : Sequence <anonymous>
> DEBUG SequenceMediator End : Sequence <main>
> Sample 9
> DEBUG SendMediator End : Send mediator
> DEBUG SequenceMediator End : Sequence <main>
> DEBUG SendMediator End : Send mediator
> DEBUG SequenceMediator End : Sequence <main>
> Issue 7
> ======
> When a sequence exists in a configuration where it refers to another sequence through
a reference key, the logs are written as follows. (Refers to the sequence as anonymous)
> DEBUG SequenceMediator Start : Sequence <anonymous>
> This should be removed
> Issue 8
> ======
> When executing sample 700 (xquery), it prints the xquery code segment twice with different
headings. IMO one of these should be removed.
> 2007-10-16 10:11:51,517 [127.0.1.1-testc-ubuntu] [HttpServerWorker-1] DEBUG XQueryMediator
Picked up the xquery source 
>   declare namespace m0="http://services.samples/xsd";
>   declare variable $payload as document-node() external;
>   <m:getQuote xmlns:m="http://services.samples/xsd">
>     <m:request>
>       <m:symbol>{$payload//m0:CheckPriceRequest/m0:Code/child::text()}</m:symbol>
>     </m:request>
>   </m:getQuote>

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: synapse-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: synapse-dev-help@ws.apache.org


Mime
View raw message