synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Asankha C. Perera" <asan...@wso2.com>
Subject Re: Possible to force proxy endpoint to use HTTP 1.0 instead of HTTP 1.1
Date Wed, 14 Nov 2007 07:47:33 GMT
Hi John

Please set the property "FORCE_HTTP_1.0" to "true" at scope "axis2" to 
use HTTP 1.0 for outgoing requests. Do this before you send the message 
out in your sequence etc.

i.e. 
<property name="FORCE_HTTP_1.0" value="true" scope="axis2" />
<send>
....


asankha

J Bouck wrote:
> I am trying the proxy a .NET-based web service that needs the
> content-length header if HTTP 1.1 is used.  I am using Synapse 1.1
> final and the synapse default for proxies appears to be HTTP 1.1 (even
> if the request to the proxy is HTTP 1.0).
> Is it possible to configure the proxy service in synapse to use HTTP 1.0?
> I find some posts regarding a custom property, something like:
> <property name="__CHUNKED__" value="false" scope="axis2" />
> will that property work with service proxies?  Where in the synapse
> config for the proxy would that property be set?
> ~john
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: synapse-dev-unsubscribe@ws.apache.org
> For additional commands, e-mail: synapse-dev-help@ws.apache.org
>
>
>   

---------------------------------------------------------------------
To unsubscribe, e-mail: synapse-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: synapse-dev-help@ws.apache.org


Mime
View raw message