synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ruwan Linton (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (SYNAPSE-232) Wrong packages in Maven repository
Date Mon, 10 Mar 2008 15:49:46 GMT

     [ https://issues.apache.org/jira/browse/SYNAPSE-232?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ruwan Linton resolved SYNAPSE-232.
----------------------------------

    Resolution: Fixed

This issue is now fixed with the 1.1.2 jars being available in the repos.

> Wrong packages in Maven repository
> ----------------------------------
>
>                 Key: SYNAPSE-232
>                 URL: https://issues.apache.org/jira/browse/SYNAPSE-232
>             Project: Synapse
>          Issue Type: Bug
>            Reporter: Maciej Majewski
>             Fix For: 1.1.1
>
>
> When using packages from http://repo1.maven.org i got:
> 18:08:33,204 ERROR [STDERR] Exception in thread "I/O dispatcher 3" 
> 18:08:33,204 ERROR [STDERR] java.lang.NoClassDefFoundError: org/apache/http/params/HttpParamsLinker
> 18:08:33,205 ERROR [STDERR]     at org.apache.synapse.transport.nhttp.ClientHandler.connected(ClientHandler.java:163)
> 18:08:33,205 ERROR [STDERR]     at org.apache.synapse.transport.nhttp.LoggingNHttpClientHandler.connected(LoggingNHttpClientHandler.java:57)
> 18:08:33,205 ERROR [STDERR]     at org.apache.synapse.transport.nhttp.PlainClientIOEventDispatch.connected(PlainClientIOEventDispatch.java:59)
> 18:08:33,205 ERROR [STDERR]     at org.apache.http.impl.nio.reactor.BaseIOReactor.keyCreated(BaseIOReactor.java:182)
> 18:08:33,205 ERROR [STDERR]     at org.apache.http.impl.nio.reactor.AbstractIOReactor.processNewChannels(AbstractIOReactor.java:246)
> 18:08:33,205 ERROR [STDERR]     at org.apache.http.impl.nio.reactor.AbstractIOReactor.execute(AbstractIOReactor.java:153)
> 18:08:33,205 ERROR [STDERR]     at org.apache.http.impl.nio.reactor.BaseIOReactor.execute(BaseIOReactor.java:70)
> 18:08:33,205 ERROR [STDERR]     at org.apache.http.impl.nio.reactor.AbstractMultiworkerIOReactor$Worker.run(AbstractMultiworkerIOReactor.java:318)
> 18:08:33,205 ERROR [STDERR]     at java.lang.Thread.run(Thread.java:595)
> After replacing synapse-*-1.1.1.jar packages with this available in binary distribution
everything works fine.
> Also packages' size from Maven repository difers from that in binary distribution. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@synapse.apache.org
For additional commands, e-mail: dev-help@synapse.apache.org


Mime
View raw message