synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ruwan Linton" <>
Subject Behavior of WSDLToServiceBuilder
Date Sat, 12 Apr 2008 12:55:55 GMT
Hi axis2 folks,

We (Synapse) have been using the WSDLToAxisServiceBuilder (to be more
specific WSDL11ToAxisServiceBuilder) to generate proxy services inside
synapse by using a given WSDL document. This was working fine with the Axis2
1.3 version and now we have migrated to axis2 SNAPSHOT (targeting to use the
axis2 1.4 release for our next release).

Now, when we generate the services using the above specified class, if we
try to print the WSDL of that service, it prints the WSDL with the ports
which are originally on the WSDL (the behavior is exactly the same as if we
specify the "useOriginalwsdl" to true and "modifyUserWSDLPortAddress" to
false). When we were using the axis2 1.3 this was working fine and replaced
the bindings and wsdl ports as appropriated. This causes wrong endpoint
address to be displayed in the WSDL.

Then I even tried to set the AxisEndpoint's endpointURL to null so that
allowing the printWSDL to take those values from the transports. When I did
this it shows a different URL as follows, which I think is wrong (may be I
am wrong here).

<wsdl:port name="StockQuoteProxyHttpSoap12Endpoint"
<soap12:address location="

I was expecting the address location to be something like "
http://ruwan:8080/soap/StockQuoteProxy" but there is some suffix to that.
Even with this approach the bindings has not been changed (which is OK for
the moment). Then I even tried to manually set the AxisEndpoints to the
populated service using the Utils.addEndpoints(AxisService,
AxisConfiguration) method, which resulted in the same format in the address

Could some one please help me on this?

Reference :-
[1] -
[2] -


Ruwan Linton - "Oxygenating the Web Services Platform"

View raw message