synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Asankha C. Perera (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (SYNAPSE-481) Outbound proxy server settings do not appear to be working
Date Thu, 12 Mar 2009 17:00:50 GMT

     [ https://issues.apache.org/jira/browse/SYNAPSE-481?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Asankha C. Perera resolved SYNAPSE-481.
---------------------------------------

       Resolution: Fixed
    Fix Version/s: 1.3

Fixed for plain HTTP proxying and tested with Squid

Configuration is enabled as :

    <transportSender name="http"  class="org.apache.synapse.transport.nhttp.HttpCoreNIOSender">
        <parameter name="non-blocking" locked="false">true</parameter>
        <parameter name="http.proxyHost" locked="false">localhost</parameter>
        <parameter name="http.proxyPort" locked="false">3128</parameter>
        <parameter name="http.nonProxyHosts" locked="false">localhost|moon|sun</parameter>
    </transportSender>

or via the same System properties with the above names as per standard Java norms (http://java.sun.com/j2se/1.5.0/docs/guide/net/proxies.html)

> Outbound proxy server settings do not appear to be working
> ----------------------------------------------------------
>
>                 Key: SYNAPSE-481
>                 URL: https://issues.apache.org/jira/browse/SYNAPSE-481
>             Project: Synapse
>          Issue Type: Bug
>          Components: Transports
>    Affects Versions: 1.2
>         Environment: Testing on Ubuntu Linux, Java 1.5 and 6.0
>            Reporter: Jeff Davis
>            Assignee: Asankha C. Perera
>             Fix For: 1.3
>
>
> The outbound proxy server settings, outline in this document - http://wso2.org/library/3346,
do not appear to be working. For example, I tried this setting in the axis2.xml file:
> <axisconfig name="AxisJava2.0">
>      <parameter name="Proxy">
>              <Configuration>
>                       <ProxyHost>localhost</ProxyHost>
>                       <ProxyPort>8888</ProxyPort>
>               </Configuration>
>     </parameter>
> ....other stuff
> </axisconfig> 
> My local outbound proxy that I was testing with, TinyProxy (available with most Linux
distro's) doesn't show any activity (but I've confirmed it's working properly via some other
programs) when I attempt to call a remote endpoint service. I also attempted using the Java
system properties option, but that similarly didn't appear to be work.
> Unfortunately, a lot of companies are now restricting all outbound traffic except through
a proxy, so this can be a significant problem. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@synapse.apache.org
For additional commands, e-mail: dev-help@synapse.apache.org


Mime
View raw message