synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hiranya Jayathilaka <hiranya...@gmail.com>
Subject Re: Problem while Running the Synapse sample client
Date Tue, 17 Mar 2009 08:47:50 GMT
That's odd. I haven't encountered this situation ever with the trunk. I
believe axis2-transports dependency is in the parent POM which should take
care of adding all the necessary transports jars. Is anybody else
experiencing the same problem?

Thanks,
Hiranya

On Tue, Mar 17, 2009 at 1:52 PM, Charith Wickramarachchi <
charith.dhanushka@gmail.com> wrote:

> HI devs,
>
> while trying to run the Synapse sample client in synapse trunk as follows
>
>  ant stockquote -Daddurl=
> http://localhost:8280/axis2/services/StockQuoteProxy
>
> i got a ClassNotfound exception
>
>      [java] org.apache.axis2.deployment.DeploymentException:
> org.apache.axis2.transport.tcp.TCPTransportSender
>      [java]     at
> org.apache.axis2.deployment.AxisConfigBuilder.processTransportSenders(AxisConfigBuilder.java:694)
>      [java]     at
> org.apache.axis2.deployment.AxisConfigBuilder.populateConfig(AxisConfigBuilder.java:121)
>      [java]     at
> org.apache.axis2.deployment.DeploymentEngine.populateAxisConfiguration(DeploymentEngine.java:707)
>      [java]     at
> org.apache.axis2.deployment.FileSystemConfigurator.getAxisConfiguration(FileSystemConfigurator.java:116)
>      [java]     at
> org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContext(ConfigurationContextFactory.java:64)
>      [java]     at
> org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContextFromFileSystem(ConfigurationContextFactory.java:206)
>      [java]     at samples.userguide.StockQuoteClient.executeClient(Unknown
> Source)
>      [java]     at samples.userguide.StockQuoteClient.main(Unknown Source)
>      [java] Caused by: java.lang.ClassNotFoundException:
> org.apache.axis2.transport.tcp.TCPTransportSender
>
> this is because the axis2 tcp transport jar is missing in the class path
> and they are not defined in the parent pom
>
> this can be solved by adding these jars to the classpath (by defining in
> the pom)
>
> thanks you,
>
> Charith
>
>
>
> --
> Charith Dhanushka Wickramarachchi
> http://charithwiki.blogspot.com/
>
>

Mime
View raw message