synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject Re: Some of the synapse samples seems to be failing on the trunk
Date Thu, 07 May 2009 22:31:56 GMT
Ruwan,

I fixed some issues in the sample client, so this part should work
now. My guess is that the issue in Synapse itself is related to the
recent changes around the processing of WS-Addressing headers. Anyway,
with the change you introduced in SYNAPSE-525, the sample will no
longer work as described in the documentation (though it should not
fail).

The following logs also look very strange:

2009-05-08 00:22:50,294 [-] [http-Sender I/O dispatcher-1] DEBUG
ClientHandler Received a 202 Accepted response
2009-05-08 00:22:50,294 [-] [http-Sender I/O dispatcher-1] DEBUG
SynapseCallbackReceiver Callback removed for request message id :
urn:uuid:642628F153886FD0321241734969703. Pending callbacks count : 0
2009-05-08 00:22:50,294 [-] [http-Sender I/O dispatcher-1] DEBUG
SynapseCallbackReceiver Synapse received an asynchronous response
message
2009-05-08 00:22:50,294 [-] [http-Sender I/O dispatcher-1] DEBUG
SynapseCallbackReceiver Received To: null
2009-05-08 00:22:50,295 [-] [http-Sender I/O dispatcher-1] DEBUG
SynapseCallbackReceiver SOAPAction: null
2009-05-08 00:22:50,295 [-] [http-Sender I/O dispatcher-1] DEBUG
SynapseCallbackReceiver WSA-Action: null
2009-05-08 00:22:50,295 [-] [http-Sender I/O dispatcher-1] DEBUG
SynapseCallbackReceiver Body :
<?xml version='1.0' encoding='utf-8'?><soapenv:Envelope
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Body
/></soapenv:Envelope>
2009-05-08 00:22:50,297 [-] [http-Sender I/O dispatcher-1] DEBUG
Axis2SynapseEnvironment Injecting MessageContext
2009-05-08 00:22:50,298 [-] [http-Sender I/O dispatcher-1] DEBUG
Axis2SynapseEnvironment Using Main Sequence for injected message

Andreas

On Wed, May 6, 2009 at 16:25, Ruwan Linton <ruwan.linton@gmail.com> wrote:
> well, for the sample 4 it is the expected behavior where as sample 13 seems
> to be really failingĀ  :-)
>
> On Wed, May 6, 2009 at 7:50 PM, Ruwan Linton <ruwan.linton@gmail.com> wrote:
>>
>> Folks,
>>
>> I have started to go through the samples one by one because we are just in
>> front of a release, and realized that some of the samples are failing. For
>> the moment the sample 4 is failing and it seems the sample 13 is also
>> failing.
>>
>> I will keep the list updated on the failing samples... we need to fix them
>> before the final release.
>>
>> Thanks,
>> Ruwan
>>
>> --
>> Ruwan Linton
>> Senior Software Engineer & Product Manager; WSO2 ESB; http://wso2.org/esb
>> WSO2 Inc.; http://wso2.org
>> email: ruwan@wso2.com; cell: +94 77 341 3097
>> blog: http://ruwansblog.blogspot.com
>
>
>
> --
> Ruwan Linton
> Senior Software Engineer & Product Manager; WSO2 ESB; http://wso2.org/esb
> WSO2 Inc.; http://wso2.org
> email: ruwan@wso2.com; cell: +94 77 341 3097
> blog: http://ruwansblog.blogspot.com
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@synapse.apache.org
For additional commands, e-mail: dev-help@synapse.apache.org


Mime
View raw message