synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Supun Kamburugamuva <supu...@gmail.com>
Subject Re: Sample 56 and WSDLEndpoints are not working
Date Mon, 04 May 2009 03:48:21 GMT
Andreas,

Even though I mentioned it as a NPE, I didn't see it in console.
getContext() method clearly returned a null and we were calling a method on
this null value. So it should be a NPE. It was strange, that error didn't
appear in the console.

Thanks,
Supun..




On Sun, May 3, 2009 at 11:05 PM, Andreas Veithen
<andreas.veithen@gmail.com>wrote:

> Supun,
>
> I added the ManagedLifecycle interface to SendMediator and this fixes
> the issue with sample 56. The strange thing is that I didn't see the
> NullPointerException as described in SYNAPSE-541. Under which
> circumstances did you see this NPE?
>
> Andreas
>
> On Sun, May 3, 2009 at 18:38, Supun Kamburugamuva <supun06@gmail.com>
> wrote:
> > Hi Andreas,
> >
> > I've attached a patch WSDL endpoint not working issue.
> >
> > https://issues.apache.org/jira/browse/SYNAPSE-541
> >
> > Thanks,
> > Supun..
> >
> > On Sun, May 3, 2009 at 7:17 PM, Andreas Veithen <
> andreas.veithen@gmail.com>
> > wrote:
> >>
> >> I recently updated sample_proxy_1.wsdl because it was no longer
> >> compatible with the service exposed by the sample Axis2 server. This
> >> caused problems when invoking the proxy service in sample 150 (and
> >> others) using SOAP UI. I didn't notice that the same WSDL was also
> >> used to demonstrate WSDL endpoints, so I left DUMMY as host address
> >> (which is OK when used with publishWSDL). This is now fixed, but
> >> sample 56 is still not working correctly: the response from the sample
> >> Axis2 server is received by Synapse, but never sent back to the
> >> client.
> >>
> >> Andreas
> >>
> >> On Sat, May 2, 2009 at 05:41, Supun Kamburugamuva <supun06@gmail.com>
> >> wrote:
> >> > Hi all,
> >> > I was trying to run sample 56. But I couldn't due to several reasons.
> >> > Sample 56 refers the sample_proxy_1.wsdl. The endpoint refers the
> >> > service SimpleStockQuoteService and
> >> > port SimpleStockQuoteServiceSOAP11port_http. But this port name has
> >> > changed
> >> > in the wsdl. So we cannot even start synapse with sample 56.
> >> > Also in the wsdl the destination addresses are specified as DUMMY.
> >> > There is a simple bug in WSDLEndpoint. I've attached a patch for this
> >> > bug.
> >> > https://issues.apache.org/jira/browse/SYNAPSE-541
> >> > I didn't touch the sample wsdl or sample configuration as I'm not
> clear
> >> > about the rationale behind those changes.
> >> > Thanks,
> >> > Supun.
> >> > --
> >> > Software Engineer, WSO2 Inc
> >> > http://wso2.org
> >> > supunk.blogspot.com
> >> >
> >> >
> >> >
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: dev-unsubscribe@synapse.apache.org
> >> For additional commands, e-mail: dev-help@synapse.apache.org
> >>
> >
> >
> >
> > --
> > Software Engineer, WSO2 Inc
> > http://wso2.org
> > supunk.blogspot.com
> >
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@synapse.apache.org
> For additional commands, e-mail: dev-help@synapse.apache.org
>
>


-- 
Software Engineer, WSO2 Inc
http://wso2.org
supunk.blogspot.com

Mime
View raw message