synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Heshan Suriyaarachchi <heshan.suriyaarach...@gmail.com>
Subject Re: Problems encountered building Synapse trunk
Date Tue, 14 Sep 2010 15:40:09 GMT
Hi Graeme,

Try building Apache Axiom first.

[1] -
https://svn.apache.org/repos/asf/webservices/commons/trunk/modules/axiom

On Tue, Sep 14, 2010 at 6:54 PM, Graeme Jenkinson <
graemejenkinson01@hotmail.com> wrote:

>  Hi all,
>
> I am attempting (for the first time) to build the Synapse to gain the
> ability to configure a HTTP proxy in the axis2.xml file (which I understand
> isn't supporting in Synapse 1.2). I have checked out the source from the
> repository and have installed Maven. Following the Synapse build
> instructions I then execute: mvn clean install. However, I end up witha
> number of errors that look like:
>
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Failed to resolve dependencies for one or more projects in the
> reactor. Reason: Missing:
> ----------
> 1) org.apache.ws.commons.axiom:axiom-api:jar:1.2.10-SNAPSHOT
>
>   Try downloading the file manually from the project website.
>
>   Then, install it using the command:
>       mvn install:install-file -DgroupId=org.apache.ws.commons.axiom
> -DartifactId=axiom-api -Dversion=1.2.10-SNAPSHOT -Dpackaging=jar
> -Dfile=/path/to/file
>
>   Alternatively, if you host your own repository you can deploy the file
> there:
>       mvn deploy:deploy-file -DgroupId=org.apache.ws.commons.axiom
> -DartifactId=axiom-api -Dversion=1.2.10-SNAPSHOT -Dpackaging=jar
> -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
>
>   Path to dependency:
>       1) org.apache.synapse:Apache-Synapse:pom:2.0.0-SNAPSHOT
>       2) org.apache.neethi:neethi:jar:2.0.4
>       3) org.apache.ws.commons.axiom:axiom-api:jar:1.2.10-SNAPSHOT
>
> 2) org.apache.sandesha2:sandesha2-core:jar:SNAPSHOT
>
>   Try downloading the file manually from the project website.
>
>   Then, install it using the command:
>       mvn install:install-file -DgroupId=org.apache.sandesha2
> -DartifactId=sandesha2-core -Dversion=20100205.143004-2 -Dpackaging=jar
> -Dfile=/path/to/file
>
>   Alternatively, if you host your own repository you can deploy the file
> there:
>       mvn deploy:deploy-file -DgroupId=org.apache.sandesha2
> -DartifactId=sandesha2-core -Dversion=20100205.143004-2 -Dpackaging=jar
> -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
>
>   Path to dependency:
>       1) org.apache.synapse:Apache-Synapse:pom:2.0.0-SNAPSHOT
>       2) org.apache.sandesha2:sandesha2-core:jar:SNAPSHO
>
> I am not at all familiar with Maven so I can't diagnose why these
> dependencies are not picked up from the Maven repositories. I've tried to
> manually brute force a solution by installing the missing dependencies but I
> don't feel that this is either the correct or productive approach.
>
> Is there something obvious that I have done wrong that would result in
> these errors?
>
> My goal is simply to build Synapse with the ability to configure a HTTP
> proxy, unfortunately I don't have the time to address my lack of familiarity
> with Maven and Synapse's build processes.
>
> thanks,
>
> Graeme
>
>
>


-- 
Regards,
Heshan Suriyaarachchi

http://heshans.blogspot.com/

Mime
View raw message