synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Supun Kamburugamuva (JIRA)" <j...@apache.org>
Subject [jira] Commented: (SYNAPSE-715) Refactoring and improving the code in HttpCoreNIOListener, ServerHandler and ServerWorker classes
Date Mon, 10 Jan 2011 05:27:48 GMT

    [ https://issues.apache.org/jira/browse/SYNAPSE-715?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12979476#action_12979476
] 

Supun Kamburugamuva commented on SYNAPSE-715:
---------------------------------------------

I think it is better to rename RequestProcessingContext to ListnerRequest or SourceRequest.

Thanks,
Supun..

> Refactoring and improving the code in HttpCoreNIOListener, ServerHandler and ServerWorker
classes
> -------------------------------------------------------------------------------------------------
>
>                 Key: SYNAPSE-715
>                 URL: https://issues.apache.org/jira/browse/SYNAPSE-715
>             Project: Synapse
>          Issue Type: Improvement
>          Components: Transports
>            Reporter: Amila Maharachchi
>            Priority: Minor
>         Attachments: synapse_nhttp_refactor.patch
>
>
> While I was going through the code of nhttp transport, I found some places where I thought
the code can be refactored in order to make it more clear and nicer. Current code has quite
a lot of parameters passing to the ServerHandler and ServerWorker contructors (respectively
8 and 11). There are quite a few common parameters among these which are passed from the HttpCoreNIOListener
to ServerHandler and then to the ServerWorker.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@synapse.apache.org
For additional commands, e-mail: dev-help@synapse.apache.org


Mime
View raw message