synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiranya Jayathilaka (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (SYNAPSE-894) [Iterate Mediator] - Unwanted tags attached to the payload if preservePayload="false"
Date Tue, 16 Jul 2013 18:02:49 GMT

     [ https://issues.apache.org/jira/browse/SYNAPSE-894?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Hiranya Jayathilaka reassigned SYNAPSE-894:
-------------------------------------------

    Assignee: Hiranya Jayathilaka
    
> [Iterate Mediator] - Unwanted tags attached to the payload if preservePayload="false"
> -------------------------------------------------------------------------------------
>
>                 Key: SYNAPSE-894
>                 URL: https://issues.apache.org/jira/browse/SYNAPSE-894
>             Project: Synapse
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.1
>         Environment: ubuntu 12.04
>            Reporter: Dushan Sachinda Abeyruwan
>            Assignee: Hiranya Jayathilaka
>            Priority: Critical
>             Fix For: FUTURE
>
>         Attachments: IterateMediator.java.patch
>
>
> 1. I have a request as below 
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
>    <soapenv:Body>
>       <m0:requestQuotes xmlns:m0="http://services.samples">
>          <m0:getQuote>
>             <m0:request>
>                <m0:symbol>IBM</m0:symbol>
>             </m0:request>
>          </m0:getQuote>
>          <m0:getQuote>
>             <m0:request>
>                <m0:symbol>IBM3</m0:symbol>
>             </m0:request>
>          </m0:getQuote>
>         <m0:getQuote>
>             <m0:request>
>                <m0:symbol>DLL</m0:symbol>
>             </m0:request>
>          </m0:getQuote>
>       </m0:requestQuotes>
>    </soapenv:Body>
> </soapenv:Envelope>
> 2. I specified the iterate configuration as following. 
>  <proxy name="IteratorProxy" transports="https http" startOnLoad="true" trace="disable">
>         <description/>
>         <target>
>             <inSequence>
>                 <iterate xmlns:m0="http://services.samples" id="iterate1" expression="//m0:requestQuotes/m0:getQuote">
>                     <target>
>                         <sequence>
>                             <log level="custom">
>                                 <property name="MESSAGE" value="##Iterating"/>
>                             </log>
>                             <log level="full"/>
>                             <send receive="StockResponseSequence">
>                                 <endpoint>
>                                     <address uri="http://localhost:9001/services/SimpleStockQuoteService"/>
>                                 </endpoint>
>                             </send>
>                         </sequence>
>                     </target>
>                 </iterate>
>             </inSequence>
>             <outSequence>
>                 <send/>
>             </outSequence>
>         </target>
>         <publishWSDL uri="http://localhost:9000/services/SimpleStockQuoteService?wsdl"/>
> </proxy> 
> <sequence name="StockResponseSequence">
>         <aggregate id="iterate1">
>             <completeCondition>
>                 <messageCount min="-1" max="-1"/>
>             </completeCondition>
>             <onComplete xmlns:ns="http://services.samples" expression="//ns:getQuoteResponse">
>                    <send/>
>             </onComplete>
>         </aggregate>
>     </sequence>
> 4. When invoked, I see a message like below 
> <?xml version='1.0' encoding='utf-8'?> 
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"> 
> <soapenv:Body> 
>        <m0:requestQuotes xmlns:m0="http://services.samples"> ----> Is this required?

> <m0:getQuote> 
> </m0:getQuote> 
> </m0:requestQuotes> 
>         <m0:request xmlns:m0="http://services.samples"> 
> <m0:symbol>IBM4</m0:symbol> 
>         </m0:request> 
> </soapenv:Body> 
> </soapenv:Envelope> 
> Why does it attach <m0:requestQuotes xmlns:m0="http://services.samples"><m0:getQuote></m0:getQuote></m0:requestQuotes>
part to the XML? Is this the correct behavior? 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@synapse.apache.org
For additional commands, e-mail: dev-help@synapse.apache.org


Mime
View raw message