synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shafreen <anfar.shafr...@gmail.com>
Subject Re: Something has gone wrong in the github daily build workflow
Date Mon, 21 Sep 2020 14:32:56 GMT
Hi All,

It seems the badge is broken, should we remove it ?


On Wed, Sep 16, 2020 at 8:50 PM Shafreen <anfar.shafreen@gmail.com> wrote:

> On Mon, Aug 24, 2020 at 10:40 PM Vanjikumaran Sivajothy <
> vanjikumaran@gmail.com> wrote:
>
>> Ack,
>> Was there any documented anomaly?
>>
>
> Sorry for the late reply. It seems the issue is happening when building
> with java 8. I could see a few NPEs in the log file, which is caused when
> setting up the SSL connection. This only happens in the github environment.
> I could not reproduce this locally. However, it seems others don't have the
> same problem. I did a bit of googling but no luck.
>
> For now, I have removed [1] Java 8 from both daily and PR builds. I am
> further looking into this. Once I figure it out, I will incorporate java 8
> back into the build.
>
> [1] https://github.com/apache/synapse/pull/49
>
>
>>
>> On Mon, Aug 24, 2020 at 9:31 AM Shafreen <anfar.shafreen@gmail.com>
>> wrote:
>>
>>> Hi All,
>>>
>>> Please find the fix for the daily build. Basically, for now I have
>>> removed the build matrix and just configured the build to run on
>>> latest-ubuntu with Java 8. I will send another PR to include a workflow to
>>> build on windows.
>>>
>>> https://github.com/apache/synapse/pull/48
>>>
>>> On Tue, Aug 11, 2020 at 10:39 PM Shafreen <anfar.shafreen@gmail.com>
>>> wrote:
>>>
>>>> Hi All,
>>>>
>>>> It seems something has gone wrong in the github daily build workflow. I
>>>> think this is due to some changes on github side. I am looking into it.
>>>>
>>>> Thanks,
>>>> Shafreen
>>>>
>>>
>>
>> --
>> Best Regards,
>> Vanji
>>
>

Mime
View raw message