tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geoff Longman" <glong...@intelligentworks.com>
Subject Re: Log4j question - Spindle requirement?
Date Tue, 04 Feb 2003 15:23:50 GMT
Oh yes, and since I can't rebuild the jaxp stuff, Spindle support for 2.4 will only work if
Eclipse is run under JDK 1.4
That is assuming that the jaxp stuff in 1.4 doesn't also cause the classloader issues. If
it does I'm sunk and can't use xerces.
(Which means I'm back at square 1)
  ----- Original Message ----- 
  From: Geoff Longman 
  To: tapestry-dev@jakarta.apache.org 
  Sent: Tuesday, February 04, 2003 10:21 AM
  Subject: Log4j question - Spindle requirement?


  I have to rebuild tapestry, commons-logging and log4j for Spindle as there is a clash in
the versions of the org.w3c and sax stuff used by crimson vs. xerces.
  Otherwise, there are Eclipse classloader problems that prevent Tapestry classes from loading
(that is a very condensed explanation of  something that has had me pulling my hair out for
two days).

  There is the option of building log4j *without* mail, jmx, and jms support. I think I can
forgo this support as my log4j jar will be used only in Spindle. Any reason this assumption
is screwed?

  Geoff

  Geoffrey Longman
  Intelligent Works Inc.



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message