tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "F.R. Da Costa Gomez" <...@fixed.com>
Subject Tomcat 4.1.24 and commons-digester-1.4
Date Thu, 27 Mar 2003 16:01:44 GMT
Hi,

Just downed 2.4-a5 and tried to continue, using Tomcat 4.1.24.
Unfornunately something boring happened on the commons-digester-1.4.jar 
file.
I have all the req Tapestry jars in the common/lib dir because it saves 
me from deploying it every time in WEB-INF/lib.
It has been working totally ok with 4.1.21 (however when putting a5 in 
there it also ceased to start).

Enter a5 with the commons-digester-1.4. Copy into TC-HOME/common/lib and 
Tomcat doesn't want to play any more. Take out commons-digester-1.4.jar 
and all is fine again.
Since I'm no Tomcat whiz I did a 1 by one copy of the Tapestry jars into 
TC-HOME/common/lib to make sure this digest jar was the culprit.
Even tried with the org 1.4.1 version from Apache-Commons itself.

Default the TC dir carries two other commons entries as well so putting 
commons-digester-1.4.jar in there does not strike me as non-logical.
Not putting the digest jar in the same dir but in the WEB_INF/lib makes 
TC start but it cannot find the app. A bit surprising because the war is 
based on exactly the same files as the last run on a4.

I assume the digest jar is in there for a reason so taking it out 
strikes me as a tad drastic but at this point I'm stuck.
If someone has a suggestion, please feel free.
Maybe puting this to the Tomcat list as well?

Cheers,

Fermin DCG


Mime
View raw message