tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Sell <christian.s...@netcologne.de>
Subject [solved] help: page not found
Date Tue, 22 Apr 2003 13:09:17 GMT
ok, got it. I had removed the init-param from the servlet declaration, 
and was not aware that tapestry now went looking for the app-spec under 
the name of the servlet.
A possible improvement would be if tapestry had made it explicit that it 
hadnt found any app-spec

Christian Sell wrote:
> Hello,
> 
> I tried to adapt my application (which was classpath-boud) to the new 
> layout. Moved everything under WEB-INF, with the .application file at 
> the root, and everything else in a "templates" subdirectory.
> 
> Changed the page declarations thus:
> 
> <application name="Tapestry Demo">
>     <page name="Home" specification-path="templates/Home.page"/>
> 
> Now I get an error "Page 'Home' not found in application namespace.". In 
> the docs for page/specification-path, I read:
> 
> "The path to the page's specification, which may be absolute (start with 
> a leading slash), or relative to the application or library specification."
> 
> I think I am using a relative path. What am I doing wrong? Where should 
> file be placed?
> 
> thanks,
> Christian
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tapestry-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tapestry-dev-help@jakarta.apache.org
> 
> 



Mime
View raw message