tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 24467] New: - Compatibility of the AbstractEngine to servlet-api 2.2
Date Thu, 06 Nov 2003 14:20:19 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=24467>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=24467

Compatibility of the AbstractEngine to servlet-api 2.2

           Summary: Compatibility of the AbstractEngine to servlet-api 2.2
           Product: Tapestry
           Version: 3.0
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Framework
        AssignedTo: tapestry-dev@jakarta.apache.org
        ReportedBy: Michael.Frericks@sparkassen-informatik.de


The class AbstractEngine prevents the usage of
Tapestry 3.0-beta-3 under an servlet engine supporting
the servlet-api 2.2 (like ibm websphere 4.0).

The AbstractEngine throws a NoSuchMethodError
in the method AbtractEngine.setupForRequest
on calling the method

request.setCharacterEncoding(encoding);

Wouldn't it be nice to include
a catch-block for backward compatibility
to servlet-api 2.2 like this:

        if (encoding == null)
        {
            encoding = getOutputEncoding();
            try
            {
                request.setCharacterEncoding(encoding);
            }
            catch (UnsupportedEncodingException e)
            {
                throw new IllegalArgumentException(
                    Tapestry.format("illegal-encoding", encoding));
            }
            catch (NoSuchMethodError e)
            {
               // due to compatibility to servletapi 2.2
            }
        }

---------------------------------------------------------------------
To unsubscribe, e-mail: tapestry-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tapestry-dev-help@jakarta.apache.org


Mime
View raw message