tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mindbri...@apache.org
Subject cvs commit: jakarta-tapestry/doc/src/UsersGuide configuration.xml
Date Sat, 29 Nov 2003 08:40:25 GMT
mindbridge    2003/11/29 00:40:25

  Modified:    doc/src/UsersGuide configuration.xml
  Log:
  Added a section on supported versions
  
  PR: 24393 No JVM requirements mentioned in docs 
  
  Revision  Changes    Path
  1.12      +79 -3     jakarta-tapestry/doc/src/UsersGuide/configuration.xml
  
  Index: configuration.xml
  ===================================================================
  RCS file: /home/cvs/jakarta-tapestry/doc/src/UsersGuide/configuration.xml,v
  retrieving revision 1.11
  retrieving revision 1.12
  diff -u -r1.11 -r1.12
  --- configuration.xml	25 Nov 2003 14:08:15 -0000	1.11
  +++ configuration.xml	29 Nov 2003 08:40:25 -0000	1.12
  @@ -3,6 +3,82 @@
   <chapter id="configuration">
   	<title>Configuring Tapestry</title>
   	
  +<section id="configuration.requirements">
  +	<title>Requirements</title>
  +	
  +<para>
  +Tapestry is designed to operate on a variety of different JVMs and versions of 
  +the Java Servlet API. Below you can find the list of supported and 
  +tested configurations:
  +</para>
  +
  +<variablelist>
  +	<title>Supported Java Versions</title>
  +	
  +<varlistentry>
  +	<term>Java 1.2.2</term>
  +	
  +	<listitem>
  +	<para>
  +	Operates correctly. Requires the Xerces parser to be in the classpath 
  +	(usually provided by the servlet container).
  +	</para>
  +	</listitem>
  +</varlistentry>
  +	
  +<varlistentry>
  +	<term>Java 1.3.x</term>
  +	
  +	<listitem>
  +	<para>
  +	Operates correctly. Requires the Xerces parser to be in the classpath
  +	(usually provided by the servlet container).
  +	</para>
  +	</listitem>
  +</varlistentry>
  +	
  +<varlistentry>
  +	<term>Java 1.4.x (recommended)</term>
  +	
  +	<listitem>
  +	<para>
  +	Operates correctly.
  +	</para>
  +	</listitem>
  +</varlistentry>
  +
  +</variablelist>
  +
  +
  +
  +<variablelist>
  +	<title>Supported Java Servlet API Versions</title>
  +	
  +<varlistentry>
  +	<term>Java Servlet API 2.2</term>
  +	
  +	<listitem>
  +	<para>
  +	Operates correctly with minor exceptions related to character encoding 
  +	of the requests due to the limitations of the Servlet API version.
  +	</para>
  +	</listitem>
  +</varlistentry>
  +	
  +<varlistentry>
  +	<term>Java Servlet API 2.3 (recommended)</term>
  +	
  +	<listitem>
  +	<para>
  +	Operates correctly.
  +	</para>
  +	</listitem>
  +</varlistentry>
  +	
  +</variablelist>
  +
  +</section>
  +
   <section id="configuration.deployment-descriptor">
   	<title>Web Deployment Descriptor</title>
   	
  @@ -630,8 +706,8 @@
   the character set used by the Russian templates, such as Home_ru.html. 
   This allows templates for different locales to use different character sets, 
   even though they are in the same application. 
  -For example, all Russian templates in the application to use the KOI8-R character set 
  -and all Chinese templates to use Big5 at the same time.
  +For example, it is possible for all Russian templates in the application to use the KOI8-R

  +character set and all Chinese templates to use Big5 at the same time.
   </para>
   
   <para>
  
  
  

---------------------------------------------------------------------
To unsubscribe, e-mail: tapestry-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tapestry-dev-help@jakarta.apache.org


Mime
View raw message