tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 29384] New: - array of custom objects as 'in' parameter fails
Date Fri, 04 Jun 2004 05:22:54 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=29384>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=29384

array of custom objects as 'in' parameter fails

           Summary: array of custom objects as 'in' parameter fails
           Product: Tapestry
           Version: 3.0
          Platform: Other
        OS/Version: Other
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Framework
        AssignedTo: tapestry-dev@jakarta.apache.org
        ReportedBy: vjeran@tis.hr


When I want to pass array of objects as "in" parameter to my component I
declare in component specification :
<parameter name="objects" type="java.lang.Object[]" direction="in" />
and in component class:
public abstract Object[] getObjects();
and everything works fine.

But when I try same thing with custom class User :
<parameter name="users" type="com.mycompany.User[]" direction="in" />
public abstract User[] getUsers();

it raises ClassNotFoundException: com.mycompany.User[]
org.apache.tapestry.ApplicationRuntimeException: Could not load class
com.mycompany.User[] from WebappClassLoader
 at
org.apache.tapestry.util.DefaultResourceResolver.findClass(DefaultResourceRe
solver.java:107)
 at
org.apache.tapestry.param.ParameterManager.getType(ParameterManager.java:353
)

---------------------------------------------------------------------
To unsubscribe, e-mail: tapestry-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tapestry-dev-help@jakarta.apache.org


Mime
View raw message