tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mario Siegenthaler (JIRA)" <tapestry-...@jakarta.apache.org>
Subject [jira] Commented: (TAPESTRY-544) Unmatched <p> and DatePicker problem in MSIE 6
Date Sat, 05 Nov 2005 13:33:20 GMT
    [ http://issues.apache.org/jira/browse/TAPESTRY-544?page=comments#action_12356849 ] 

Mario Siegenthaler commented on TAPESTRY-544:
---------------------------------------------

As far as I tracked down this issue the problem is that the IE really dislikes the <script>
of the DatePicker if it's not a top level element (directly under the body). I got the same
'operation aborted' message.
The only solution that worked was to open and close all elements properly. I even had a problem
with a <div/> tag I had to change to <div></div> because the IE was too
stupid to recognize the first one as closed. Maybe it's the same problem here. I'd try a <p></p>.
In such a scenario I found the IE-Webdeveloper Toolbars DOM-Inspector to be a great help.

> Unmatched <p> and DatePicker problem in MSIE 6
> ----------------------------------------------
>
>          Key: TAPESTRY-544
>          URL: http://issues.apache.org/jira/browse/TAPESTRY-544
>      Project: Tapestry
>         Type: Bug
>   Components: Framework
>     Versions: 4.0
>  Environment: MSIE 6.0, Windows XP SP 2
>     Reporter: David Bergman

>
> This concerns all beta versions of 4.0, even including tonight's CVS HEAD, which is supposed
to be Beta-4.
> Whenever I use an unmatched <p>, or even a <p/>, without an explicit </p>
in a page with a DatePicker, I get a really strange error from MSIE, in that MSIE pops up
the error dialog "Operation aborted." It does NOT happen when I match the <p> tag with
a </p> or use other components, such as TextField.
> The simplest page yielding this problem:
> <html>
> <body jwcid="@Body">
> <p/>
> <form jwcid="@Form">
> <input jwcid="@DatePicker" value="ognl:theDate" type="text" size="12" />
> </form>
> </body>
> </html>
> Just remove the <p/> and it works. Very absurd. Have tried with a handful of MSIE
6 machines.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: tapestry-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tapestry-dev-help@jakarta.apache.org


Mime
View raw message