tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ben Sommerville" <...@bulletproof.com.au>
Subject RE: Can't build code from SVN trunk
Date Sun, 12 Aug 2007 08:39:29 GMT
That error occurs when you try to compile with java 6.  It doesn't
occur under java 5.  I haven't had time to look into exactly why 6
throws an error there, but if you change the appropriate line in
ChainBuilder it all builds/runs fine.

Otherwise you can drop back to java 5.

cheers,
Ben

> -----Original Message-----
> From: Julien HENRY [mailto:henryju@yahoo.fr] 
> Sent: Saturday, 11 August 2007 7:14 AM
> To: dev@tapestry.apache.org
> Subject: Can't build code from SVN trunk
> 
> Hi all,
> 
> I'm trying to build T5 from trunk, but I get this
> error:
> 
> [ERROR] BUILD FAILURE
> [INFO]
> --------------------------------------------------------------
> ----------
> [INFO] Compilation failure
> 
> /home/julien/tapestry-project/tapestry-ioc/src/main/java/org/a
pache/tapestry/ioc/internal/services/ChainBuilderImpl.java:[125,> 65]
> incompatible types
> found   : java.lang.reflect.Constructor<?>
> required: java.lang.reflect.Constructor<T>
> 
> FYI:
> $ mvn -v
> Maven version: 2.0.7
> Java version: 1.6.0_02
> OS name: "linux" version:
> "2.6.17.14-mm-desktop-6mdvsmp" arch: "i386"
> 
> Hope you can fix it or tell me what I did wrong.
> 
> Best regards,
> 
> Julien
> 
> 
>       
> ______________________________________________________________
> _______________
> Ne gardez plus qu'une seule adresse mail ! Copiez vos mails 
> vers Yahoo! Mail 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@tapestry.apache.org
> For additional commands, e-mail: dev-help@tapestry.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tapestry.apache.org
For additional commands, e-mail: dev-help@tapestry.apache.org


Mime
View raw message