tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Howard M. Lewis Ship (JIRA)" <...@tapestry.apache.org>
Subject [jira] Closed: (TAPESTRY-1907) The translate parameter is marked as required but it isn't
Date Thu, 03 Jan 2008 23:26:34 GMT

     [ https://issues.apache.org/jira/browse/TAPESTRY-1907?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Howard M. Lewis Ship closed TAPESTRY-1907.
------------------------------------------

    Resolution: Invalid
      Assignee: Howard M. Lewis Ship

Often, Tapestry can determine the translator from the type of object to which the value parameter
is bound, but when that is not the case, the translator parameter is still required.

> The translate parameter is marked as required but it isn't
> ----------------------------------------------------------
>
>                 Key: TAPESTRY-1907
>                 URL: https://issues.apache.org/jira/browse/TAPESTRY-1907
>             Project: Tapestry
>          Issue Type: Improvement
>          Components: Core Components
>    Affects Versions: 5.0.6
>            Reporter: Hugo Palma
>            Assignee: Howard M. Lewis Ship
>            Priority: Minor
>
> Components like TextField and TextArea have a "translate" parameter that is stated as
being required. But in the documentation it says:
> "If not specified, a value will usually be generated based on the type of the value parameter."
> So, i think the parameter should not be annotated as required as it clearly isn't.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tapestry.apache.org
For additional commands, e-mail: dev-help@tapestry.apache.org


Mime
View raw message