tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joost Schouten (JIRA)" <j...@apache.org>
Subject [jira] Updated: (TAP5-937) LinkImpl does not handle parameters propery when passed into the constructor
Date Tue, 08 Dec 2009 08:41:18 GMT

     [ https://issues.apache.org/jira/browse/TAP5-937?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Joost Schouten updated TAP5-937:
--------------------------------

    Attachment:     (was: parameter_addition_patch.txt)

> LinkImpl does not handle parameters propery when passed into the constructor
> ----------------------------------------------------------------------------
>
>                 Key: TAP5-937
>                 URL: https://issues.apache.org/jira/browse/TAP5-937
>             Project: Tapestry 5
>          Issue Type: Bug
>          Components: tapestry-core
>    Affects Versions: 5.1
>            Reporter: Joost Schouten
>
> I noticed this after using the AjaxFormLoop AddRowLink on a page which has an onActivate
and onPassivate resulting in the addition of a "t:ac" to the url. Debugging showed me that
the t:ac is already present on instantiation of the LinkImpl. When calling toAbsoluteUri the
parameters are added in a way where they will always start with a "?". Obvisouly resulting
in an invalid URL with two ?'s
> I'm building a failing test at this stage and will provide a patch once resolved.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message