tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Shead (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TAP5-1599) Upgrade Selenium to 2.3.1
Date Tue, 09 Aug 2011 18:07:27 GMT

    [ https://issues.apache.org/jira/browse/TAP5-1599?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13081803#comment-13081803
] 

Mark Shead commented on TAP5-1599:
----------------------------------

Howard - If you look at the test times, you'll see that did not happen in my tests.  In fact
it appears that the tests can even run faster using Selenium 2.3.1 and FF 5.  Perhaps there
are certain circumstances or certain setups where they will run slower. I can try running
the tests on some other platforms to see if I run into any problems there.


> Upgrade Selenium to 2.3.1
> -------------------------
>
>                 Key: TAP5-1599
>                 URL: https://issues.apache.org/jira/browse/TAP5-1599
>             Project: Tapestry 5
>          Issue Type: Bug
>          Components: tapestry-test
>            Reporter: Mark Shead
>         Attachments: PATCH-TAP5-1599
>
>
> The current version of Selenium only works with older browsers.  Selenium 2.3.1 is almost
a drop in replacement and will allow tests to be run with Firefox 5.  At least on my setup,
Selenium 2.3.1 is not significantly slower and is sometimes faster than the current version.
 Below are the test times running on Ubuntu 11.04.
> Firefox 5:
> 5.3 Selenium 2 & Gradle
> 6:47
> 6:42
> Using Firefox 3.6:
> 5.2.6 Selenium 1 & Maven
> 6:14
> 5.3 with Selenium 1 & Gradle
> 7:05
> 7:14
> 5.3 Selenium 2 & Gradle
> 7:26
> 8:01

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message