tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bob Harner (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TAP5-1925) Rename t:remove to t:annotation
Date Sat, 05 May 2012 20:19:52 GMT

    [ https://issues.apache.org/jira/browse/TAP5-1925?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13269051#comment-13269051
] 

Bob Harner commented on TAP5-1925:
----------------------------------

The term "annotation" already has a different meaning in the Java world, so although I agree
with you that "remove" is a little unintuitive, I think "annotation" might be worse.

However, if you want to make an "annotation" component of your own, feel free. It would be
truly trivial to do:

package com.mycompany.myapp.components;
public class Annotation
{
    boolean  setupRender()
    {
        return false;
    }
}
                
> Rename t:remove to t:annotation
> -------------------------------
>
>                 Key: TAP5-1925
>                 URL: https://issues.apache.org/jira/browse/TAP5-1925
>             Project: Tapestry 5
>          Issue Type: Improvement
>          Components: tapestry-core
>    Affects Versions: 5.3.3
>            Reporter: Carsten Klein
>            Priority: Minor
>
> I am quite unhappy with the naming of the component used for server side comments/annotations
attached to a template.
> t:remove seems a bit awkward, albeit it does reflect on what the template engine actually
does.
> I would recommend deprecating t:remove and introduce a t:annotation component in its
favor.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message