tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Howard Lewis Ship <hls...@gmail.com>
Subject Re: Build failed in Jenkins: tapestry-5.3-freestyle #26
Date Tue, 01 May 2012 23:45:35 GMT
This looks troubling ... I believe the new version of Hibernate is
compiled for JDK 1.6 (classfile version 50.0).

It's either time to bite the bullet at set JDK 1.6 as a baseline ...
or at least, set up the Jenkins build to use a JDK 1.6 compiler that
can read the Hibernate JARs.

On Tue, May 1, 2012 at 4:08 PM, Apache Jenkins Server
<jenkins@builds.apache.org> wrote:
> See <https://builds.apache.org/job/tapestry-5.3-freestyle/26/changes>
>
> Changes:
>
> [hlship] Upgrade to Gradle 1.0-rc-3
> Fix a number of Gradle warnings from the upgrade
> Copy the root project's gradle wrapper into the quickstart archetype
>
> ------------------------------------------
> Started by an SCM change
> Building remotely on ubuntu2 in workspace <https://builds.apache.org/job/tapestry-5.3-freestyle/ws/>
> Updating https://svn.apache.org/repos/asf/tapestry/tapestry5/branches/5.3
> U         tapestry-ioc/build.gradle
> U         gradlew
> U         ssh.gradle
> U         build.gradle
> U         tapestry-upload/build.gradle
> U         tapestry-core/build.gradle
> U         tapestry-hibernate/build.gradle
> U         md5.gradle
> U         tapestry-test/build.gradle
> D         quickstart/src/main/resources/archetype-resources/gradlew
> D         quickstart/src/main/resources/archetype-resources/gradlew.bat
> D         quickstart/src/main/resources/archetype-resources/gradle
> U         quickstart/build.gradle
> U         gradle/wrapper/gradle-wrapper.jar
> U         gradle/wrapper/gradle-wrapper.properties
> U         plastic/build.gradle
> U         tapestry-hibernate-core/build.gradle
> U         tapestry-func/build.gradle
> U         tapestry-spring/build.gradle
> At revision 1332875
> [tapestry-5.3-freestyle] $ /bin/bash -xe /tmp/hudson7133755019761818528.sh
> + Xvfb :6 -ac -screen 0 1024x768x8
> [dix] Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!
> [dix] Could not init font path element /usr/share/fonts/X11/100dpi/:unscaled, removing
from list!
> [dix] Could not init font path element /usr/share/fonts/X11/75dpi/:unscaled, removing
from list!
> [dix] Could not init font path element /usr/share/fonts/X11/Type1, removing from list!
> [dix] Could not init font path element /usr/share/fonts/X11/100dpi, removing from list!
> [dix] Could not init font path element /usr/share/fonts/X11/75dpi, removing from list!
> Process leaked file descriptors. See http://wiki.jenkins-ci.org/display/JENKINS/Spawning+processes+from+build
for more information
> [tapestry-5.3-freestyle] $ /bin/bash -xe /tmp/hudson4051123630186501374.sh
> + DISPLAY=:6.0
> + <https://builds.apache.org/job/tapestry-5.3-freestyle/ws/5.3/gradlew> -Dproject-version=5.3.2-SNAPSHOT
-Dfile.encoding=UTF-8 -b <https://builds.apache.org/job/tapestry-5.3-freestyle/ws/5.3/build.gradle>
continuousIntegration
> Downloading http://services.gradle.org/distributions/gradle-1.0-rc-3-bin.zip
> .........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
> Unzipping /home/hudson/.gradle/wrapper/dists/gradle-1.0-rc-3-bin/59nkhr3nl96fm3u00sr182b0pj/gradle-1.0-rc-3-bin.zip
to /home/hudson/.gradle/wrapper/dists/gradle-1.0-rc-3-bin/59nkhr3nl96fm3u00sr182b0pj
> Set executable permissions for: /home/hudson/.gradle/wrapper/dists/gradle-1.0-rc-3-bin/59nkhr3nl96fm3u00sr182b0pj/gradle-1.0-rc-3/bin/gradle
> Dynamic properties are deprecated: http://gradle.org/docs/current/dsl/org.gradle.api.plugins.ExtraPropertiesExtension.html
> Deprecated dynamic property: "jdkName" on "org.gradle.plugins.ide.idea.model.IdeaModel_Decorated@84639c",
value: "1.6".
> Deprecated dynamic property "jdkName" created in multiple locations.
> :plastic:compileJavaNote: Some input files use unchecked or unsafe operations.
> Note: Recompile with -Xlint:unchecked for details.
>
> :plastic:compileGroovy UP-TO-DATE
> :plastic:processResources UP-TO-DATE
> :plastic:classes
> :plastic:jar
> :tapestry-core:generateGrammarSource
> :tapestry-func:compileJava
> :tapestry-func:compileGroovy UP-TO-DATE
> :tapestry-func:processResources UP-TO-DATE
> :tapestry-func:classes
> :tapestry-func:jar
> :tapestry-test:compileJavaNote: Some input files use or override a deprecated API.
> Note: Recompile with -Xlint:deprecation for details.
>
> :tapestry-test:compileGroovy UP-TO-DATE
> :tapestry-test:processResources
> :tapestry-test:classes
> :tapestry-test:jar
> :tapestry5-annotations:compileJava
> :tapestry5-annotations:compileGroovy UP-TO-DATE
> :tapestry5-annotations:processResources UP-TO-DATE
> :tapestry5-annotations:classes
> :tapestry5-annotations:jar
> :tapestry-ioc:compileJavaNote: Some input files use or override a deprecated API.
> Note: Recompile with -Xlint:deprecation for details.
> Note: Some input files use unchecked or unsafe operations.
> Note: Recompile with -Xlint:unchecked for details.
>
> :tapestry-ioc:compileGroovy UP-TO-DATE
> :tapestry-ioc:processResources
> :tapestry-ioc:classes
> :tapestry-ioc:jar
> :tapestry-json:compileJava
> :tapestry-json:compileGroovy UP-TO-DATE
> :tapestry-json:processResources UP-TO-DATE
> :tapestry-json:classes
> :tapestry-json:jar
> :tapestry-core:compileJavaNote: Some input files use or override a deprecated API.
> Note: Recompile with -Xlint:deprecation for details.
> Note: Some input files use unchecked or unsafe operations.
> Note: Recompile with -Xlint:unchecked for details.
>
> :tapestry-core:compileGroovy UP-TO-DATE
> :tapestry-core:processResources
> :tapestry-core:classes
> :tapestry-core:jar
> :tapestry-hibernate-core:compileJava
> Download http://repo1.maven.org/maven2/org/hibernate/hibernate-core/4.1.1.Final/hibernate-core-4.1.1.Final.pom
> Download http://repo1.maven.org/maven2/org/jboss/logging/jboss-logging/3.1.0.GA/jboss-logging-3.1.0.GA.pom
> Download http://repo1.maven.org/maven2/org/jboss/jboss-parent/7/jboss-parent-7.pom
> Download http://repo1.maven.org/maven2/org/hibernate/hibernate-core/4.1.1.Final/hibernate-core-4.1.1.Final.jar
> Download http://repo1.maven.org/maven2/org/jboss/logging/jboss-logging/3.1.0.GA/jboss-logging-3.1.0.GA.jar
> <https://builds.apache.org/job/tapestry-5.3-freestyle/ws/5.3/tapestry-hibernate-core/src/main/java/org/apache/tapestry5/internal/hibernate/PackageNameHibernateConfigurer.java>:20:
cannot access org.hibernate.cfg.AnnotationConfiguration
> bad class file: /home/hudson/.gradle/caches/artifacts-13/filestore/org.hibernate/hibernate-core/4.1.1.Final/jar/715a4ad35bd4255e703a03e3115bb8df7e4e18d8/hibernate-core-4.1.1.Final.jar(org/hibernate/cfg/AnnotationConfiguration.class)
> class file has wrong version 50.0, should be 49.0
> Please remove or make sure it appears in the correct subdirectory of the classpath.
> import org.hibernate.cfg.AnnotationConfiguration;
>                         ^
> 1 error
>
> FAILURE: Build failed with an exception.
>
> * What went wrong:
> Execution failed for task ':tapestry-hibernate-core:compileJava'.
>> Compilation failed; see the compiler error output for details.
>
> * Try:
> Run with --stacktrace option to get the stack trace. Run with --info or --debug option
to get more log output.
>
> BUILD FAILED
>
> Total time: 4 mins 53.239 secs
> Build step 'Execute shell' marked build as failure
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@tapestry.apache.org
> For additional commands, e-mail: dev-help@tapestry.apache.org
>



-- 
Howard M. Lewis Ship

Creator of Apache Tapestry

The source for Tapestry training, mentoring and support. Contact me to
learn how I can get you up and productive in Tapestry fast!

(971) 678-5210
http://howardlewisship.com

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tapestry.apache.org
For additional commands, e-mail: dev-help@tapestry.apache.org


Mime
View raw message