tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bob Harner <bobhar...@gmail.com>
Subject Re: jQuery 2.x or stick with 1.x?
Date Mon, 27 May 2013 16:15:17 GMT
Well, according to http://www.netmarketshare.com/, as of April 2013 IE 8
still comprises 23% of desktop browsers worldwide. Because of that, the
majority of apps using Tapestry 5.4 probably must still support IE 8, no
matter how much we don't like it.

Howard or anyone, can you provide the details of how one would switch the
jQuery version in 5.4? I believe switching from Prototype to jQuery just
requires a little configuration in your module class (usually
AppModule.java):

public static void contributeApplicationDefaults(
            MappedConfiguration<String, String> configuration){
    ...
    configuration.add(SymbolConstants.JAVASCRIPT_INFRASTRUCTURE_PROVIDER,
"jquery");}
@Contribute(Compatibility.class)public static void
disableScriptaculous(MappedConfiguration configuration){
    configuration.add(Trait.SCRIPTACULOUS, false);}


On Mon, May 27, 2013 at 11:01 AM, Lenny Primak <lprimak@hope.nyc.ny.us>wrote:

> Same here. Big -1 for dropping older IE support. +1 for jq2 if we can keep
> older IE.support.
>
> On May 27, 2013, at 7:21 AM, Barry Books <trsvax@gmail.com> wrote:
>
> >> From the jQuery 2.0 release notes:
> >
> > As promised, this version leaves behind the older Internet Explorer 6, 7,
> >> and 8 browsers. In return it is smaller, faster, and can be used in
> >> JavaScript environments where the code needed for old-IE compatibility
> >> often causes problems of its own. *But don’t worry, the jQuery team
> still
> >> supports the 1.x branch which does run on IE 6/7/8.* You can (and
> should)
> >> continue to use jQuery 1.9 (and the upcoming 1.10) on web sites that
> need
> >> to accommodate older browsers.
> >
> >
> > I use Tapestry to build sites for business/government that are still
> using
> > Windows XP and are therefore stuck on IE8. Bootstrap 3.X appears it will
> > support IE8. I can see why people would rather drop older IE support but
> at
> > this point I don't think it's practical if you want your product to be
> used
> > in a business/government environment.
> >
> > So I would say if it's easy to pick (or Dmitry's suggestion) I'm OK with
> > that but if it you are talking about dropping IE8 support I would have to
> > say a *BIG* -1.
> >
> > Barry
> >
> >
> >
> >
> > On Mon, May 27, 2013 at 12:59 AM, Kristian Marinkovic <
> > kristian.marinkovic@gmail.com> wrote:
> >
> >> +1
> >> Am 26.05.2013 19:01 schrieb "Jochen Frey" <jochen@jochenfrey.com>:
> >>
> >>> +1
> >>>
> >>> -- j
> >>>
> >>> On May 26, 2013, at 9:06 AM, Emmanuel DEMEY <demey.emmanuel@gmail.com>
> >>> wrote:
> >>>
> >>>> +1 !!!
> >>>>
> >>>>
> >>>> 2013/5/26 Dimitris Zenios <dimitris.zenios@gmail.com>
> >>>>
> >>>>> +1
> >>>>>
> >>>>>
> >>>>> On Sun, May 26, 2013 at 6:58 PM, Howard Lewis Ship <hlship@gmail.com
> >
> >>>>> wrote:
> >>>>>
> >>>>>> What do people think about moving the embedded jQuery library
up to
> >> the
> >>>>> 2.x
> >>>>>> version?  I would tend to favor the idea, given that anyone
who
> truly
> >>>>> cares
> >>>>>> can switch it back.
> >>>>>>
> >>>>>> --
> >>>>>> Howard M. Lewis Ship
> >>>>>>
> >>>>>> Creator of Apache Tapestry
> >>>>>>
> >>>>>> The source for Tapestry training, mentoring and support. Contact
me
> >> to
> >>>>>> learn how I can get you up and productive in Tapestry fast!
> >>>>>>
> >>>>>> (971) 678-5210
> >>>>>> http://howardlewisship.com
> >>>>
> >>>>
> >>>>
> >>>> --
> >>>> Emmanuel DEMEY
> >>>> Ingénieur Etude et Développement
> >>>> ATOS Worldline
> >>>> +33 (0)6 47 47 42 02
> >>>> demey.emmanuel@gmail.com
> >>>> http://emmanueldemey.fr/
> >>>>
> >>>> Twitter : @EmmanuelDemey
> >>>
> >>> ---------------------------------------------------------------------
> >>> To unsubscribe, e-mail: dev-unsubscribe@tapestry.apache.org
> >>> For additional commands, e-mail: dev-help@tapestry.apache.org
> >>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@tapestry.apache.org
> For additional commands, e-mail: dev-help@tapestry.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message