tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Gusev (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TAP5-1066) Client-Id and Links in Grid not correct when putting a Grid inside a Loop
Date Tue, 02 Sep 2014 19:54:21 GMT

    [ https://issues.apache.org/jira/browse/TAP5-1066?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14118623#comment-14118623
] 

Dmitry Gusev commented on TAP5-1066:
------------------------------------

I believe this was fixed in TAP5-2256

> Client-Id and Links in Grid not correct when putting a Grid inside a Loop
> -------------------------------------------------------------------------
>
>                 Key: TAP5-1066
>                 URL: https://issues.apache.org/jira/browse/TAP5-1066
>             Project: Tapestry 5
>          Issue Type: Bug
>          Components: tapestry-core
>    Affects Versions: 5.2
>            Reporter: Matthias Jell
>             Fix For: 5.4
>
>
> I write a page with a grid component inside a loop. For every iteration result in the
loop I generate a new display bean model as grid model.
> The page will be rendered and it looks fine, but only the first grid getting a client-id
and all sorting links of all grids inside the loop use this clientId. 
> In my opinion every grid should have a single clientId.
> ....
> <t:loop source="abc" result="xyz">
>    <t:grid />
> </t:loop>



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message