tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jochen Kemnade (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TAP5-2379) Upgrade to Less4j 1.8.1 and ANTL 3.5.2
Date Mon, 01 Sep 2014 14:09:21 GMT

    [ https://issues.apache.org/jira/browse/TAP5-2379?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14117447#comment-14117447
] 

Jochen Kemnade commented on TAP5-2379:
--------------------------------------

Not exactly. What prevented the release was that in commit 7702038519af9a548de52b757446b02212f7165f
I only updated the version numbers in the actual dependencies but not in the ResolutionStrategy
overrides. So the newer versions were only used for everything that ran within Gradle's scope
(like {{compile}} and {{test}} but the JARs' poms still listed the old versions as dependencies.
As your patch also updates the override's version, it should not cause that issue. However,
as I already said on the dev list, I think we may have to talk about those overrides, i.e.
what we're trying to accomplish and if there might be a better way to do it.


> Upgrade to Less4j 1.8.1 and ANTL 3.5.2
> --------------------------------------
>
>                 Key: TAP5-2379
>                 URL: https://issues.apache.org/jira/browse/TAP5-2379
>             Project: Tapestry 5
>          Issue Type: Dependency upgrade
>          Components: tapestry-webresources
>    Affects Versions: 5.4
>            Reporter: Felix Scheffer
>              Labels: build, patch
>         Attachments: 0003-TAP5-2379-Upgrade-to-Less4j-1.8.1-and-ANTL-3.5.2.patch
>
>
> Less4j 1.8.1 is now using antlr 3.5.2 which fixes [NPE in CompositeGrammer.getIndirectDelegates
in Java 8|https://github.com/antlr/antlr3/issues/151]. 
> I think this was the issue that prevented the release of 5.4-beta-14 back in July.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message