tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Papy (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TAP5-2448) Asset.getClientURL() throws NPE if the Asset is a Folder within a SubModule JAR file
Date Thu, 05 Feb 2015 15:20:34 GMT

    [ https://issues.apache.org/jira/browse/TAP5-2448?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14307375#comment-14307375
] 

Martin Papy commented on TAP5-2448:
-----------------------------------

I agree. But in this case how would you address my need ?

On Thursday, February 5, 2015, Jochen Kemnade (JIRA) <jira@apache.org>



> Asset.getClientURL() throws NPE if the Asset is a Folder within a SubModule JAR file
> ------------------------------------------------------------------------------------
>
>                 Key: TAP5-2448
>                 URL: https://issues.apache.org/jira/browse/TAP5-2448
>             Project: Tapestry 5
>          Issue Type: Bug
>          Components: tapestry-core
>    Affects Versions: 5.4
>            Reporter: Martin Papy
>         Attachments: NPE_Stack_Trace.txt, folder.zip
>
>
> If you inject in a Field an Asset and if this Asset is actually a Folder that is embedded
into a JAR SubModule used by the main Tapestry WebApp then the method toClientURL() returns
a NPE.
> The issue does not happen when the SubModule is not yet a JAR file. Exemple : when you
are running Tomcat from Eclipse and let Eclipse manage the dependency ( I am using the Sysdeo
plugin to add dependencies to the source folders of the SubModule instead of the JAR file.
).



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message