tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thiago H de Paula Figueiredo" <thiag...@gmail.com>
Subject Re: 5.5 anyone?
Date Wed, 27 Jan 2016 12:14:45 GMT
On Tue, 26 Jan 2016 14:51:51 -0200, Bob Harner <bobharner@gmail.com> wrote:

> I don't think Jochen was proposing compiling Tapestry to anything other
> that a 1.8 level, only that if Tapestry forces users to use a 1.8 runtime
> then it doesn't mean they are forced to use 1.8 features.

Oh, I see that now. I didn't interpret it that way.
But, if we're going to force users to use a 1.8 runtime, I don't see the  
point of not using everything it provides. If someone is already using  
Java 8, I'd expect them to use the full set of features of the language.

> I'm +1 with 5.4 being maintained for jre 1.6 or 1.7 and Tapestry 5.5  
> being for jre 1.8 users, because 1) it's a way to keep devs interested,

I didn't think about this before. Good catch, Bob! I agree with you.

> and 2)
> the potential advantages of 1.8 are huge for Tapestry. One of the biggest
> would be the ability to change interfaces without breaking backward
> compatibility (via default methods).

Agreed. Another thing you've thought and I didn't, Bob. You're making me  
feel embarrassed! hehehe

-- 
Thiago H. de Paula Figueiredo
Tapestry, Java and Hibernate consultant and developer
http://machina.com.br

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tapestry.apache.org
For additional commands, e-mail: dev-help@tapestry.apache.org


Mime
View raw message