tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jochen Kemnade (JIRA)" <j...@apache.org>
Subject [jira] [Created] (TAP5-2548) Upgrade embedded Jetty and Tomcat versions
Date Wed, 18 May 2016 08:03:12 GMT
Jochen Kemnade created TAP5-2548:
------------------------------------

             Summary: Upgrade embedded Jetty and Tomcat versions
                 Key: TAP5-2548
                 URL: https://issues.apache.org/jira/browse/TAP5-2548
             Project: Tapestry 5
          Issue Type: Dependency upgrade
          Components: tapestry-runner
            Reporter: Jochen Kemnade


Since we are switching to Servlet 3.0 for Tapestry 5.5, we should upgrade the embedded server
versions.
Unfortunately the runner classes contain the servlet container versions in their class names
(Jetty7Runner and Tomcat6Runner). This means we can either stay backward compatible and confuse
users (e.g. start Jetty 8 from Jetty7Runner) or rename the classes and break backward compatibility.
I prefer the latter.
Thoughts?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message