tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Zeigler <robert.zeig...@roxanemy.com>
Subject Re: 5.5 soon?
Date Thu, 14 Jul 2016 13:33:03 GMT
I’m in favor of a transition release where we warn with the big bright warnings that in the
next release, we’ll be switching to the jQuery infrastructure by default.  I would also
suggest adding a means of determining whether people are using the out-of-the-box prototype
configuration and adding a runtime warning for those cases as an additional way of indicating
“Hey, you need to add this configuration in 5.5 so your app won’t break in 5.6”.  

Robert

> On Jul 14, 2016, at 8:13 AM, Thiago H de Paula Figueiredo <thiagohp@gmail.com>
wrote:
> 
> On Thu, 14 Jul 2016 02:30:14 -0300, Jochen Kemnade <jochen.kemnade@eddyson.de>
wrote:
> 
>> +1 to all of that.
> 
> ;)
> 
>> On a side note, should we default to the jQuery infrastructure for 5.5?
> 
> Hmm, current Prototype-based projects would just stop working out of a sudden. I'm not
a fan of changing defaults. On the other hand, we could make quickstart-generated projects
have them using jQuery and also make a big note of this configuration in the documentation,
including the tutorial. But I don't have a strong opinion on the subject.
> 
> -- 
> Thiago H. de Paula Figueiredo
> Tapestry, Java and Hibernate consultant and developer
> http://machina.com.br
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@tapestry.apache.org
> For additional commands, e-mail: dev-help@tapestry.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tapestry.apache.org
For additional commands, e-mail: dev-help@tapestry.apache.org


Mime
View raw message