tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jochen Kemnade <kemn...@gmail.com>
Subject Tapestry 5.5?
Date Tue, 10 Oct 2017 16:03:02 GMT
Hi,

you may have noticed that the most recent Tapestry release (5.4.3) does not
work with Java 9. This is mainly due to an outdated ASM release that we use
in plastic.
I have upgraded ASM to the latest stable release in the master branch,
along with some other dependencies (such as Selenium) and Gradle.
Rather than struggling with backports for 5.4, I'd say that we concentrate
on finishing 5.5.
I'm creating a 5.5-alpha-4 preview release right now and would like to move
on to beta stage (along with a first public release of the 5.5 line) soon.
Is there anything we need to do before that? Any blocker issues that come
to mind?
I've used 5.5-alpha-3 in production for several months now and have not
encountered any regression issues. Has anyone else given it a try?
Also, does anyone else have some spare time to help finish the release?

Jochen

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message